#11651 closed defect (outdated)

SCI: GK2 error when restoring saved game

Reported by: Silver1983 Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Gabriel Knight 2

Description

Hi there, I am playing Gabriel Knight 2 (GOG with ScummVM 2.0 and 2.1.1) and am visiting Ludwigs castles in chapter 4 and am experiencing a crash. Sadly it occurs every time I try to open a savegame where I am at Herrenchiemsee. Hopefully my savegame can be fixed because the next one is at aleast an hour ago.

Attachments (1)

Crash.jpg (199.1 KB ) - added by Silver1983 14 months ago.

Download all attachments as: .zip

Change History (7)

by Silver1983, 14 months ago

Attachment: Crash.jpg added

comment:1 by raziel-, 14 months ago

Game: Gabriel Knight 2
Summary: Gabriel Knight 2 CrashSCI: GK2 - Crash

Since your savegame seems already corrupted it would be really helpful if you play to the scene and provide a new one just before entering the castle resp. where the crash occurs.

comment:2 by Silver1983, 14 months ago

As unfavorably as it sounds, I will do it within the next days.

comment:3 by Silver1983, 14 months ago

I restarted from the previous chapter. Sadly I could not reproduce the issue.

comment:4 by raziel-, 14 months ago

Resolution: invalid
Status: newclosed

@Silver1983

That's ok.
Sometimes issues accumulate and ultimately break the save game by saving already broken flags.

Thanks for retrying.

If you happen to be able to reproduce this behaviour, just reopen the ticket.

Closing as invalid.

comment:5 by sluicebox, 14 months ago

Component: --Unset--Engine: SCI
Resolution: invalid
Status: closednew
Summary: SCI: GK2 - CrashSCI: GK2 error when restoring saved game

We should be cautious about closing crash reports as invalid within a few days when the component field hasn't even been set. I just stumbled on this randomly and other SCI devs likely haven't seen it yet. Someone just reported a crash bug and we've given them permission to go away and overwrite their broken save, our only clue to diagnosing this error, without any investigation.

Silver1983, can you attach the save game file(s) that failed to load? That way we can try to figure out what's wrong them. I'm assuming you're on Windows since you mentioned GOG, you can find those files at:

%userprofile%\AppData\Roaming\ScummVM\Saved games

You listed two versions of ScummVM, I'm assuming because GOG came with 2.0.0 and you then downloaded a newer version to try. Do you know which one created the saved game(s) that won't load? I'm assuming both versions error when attempting to load the files.

We've fixed a number of GK2 bugs since 2.0.0 but that error message doesn't ring a bell.

I'm re-opening this in hopes of getting Silver1983's attention. If the broken save files are gone or there's no response then it can be closed again.

comment:6 by sluicebox, 14 months ago

Owner: set to sluicebox
Resolution: outdated
Status: newclosed

Oh! I *have* seen this before: https://github.com/scummvm/scummvm/commit/b6d73f54dd2c888a5ef575e6e333dc7dac2078fe

The "purge" error in the screen shot is the edge-case I described in the comments where the room number in room 810 gets set to zero. I just reproduced it in ScummVM 2.1.0.

From the screen shot I can see that this is room 810 on ScummVM 2.0.0. Newer Windows releases use a different font or didn't include the GUI debugger at all. The fix for this room first appeared in 2.1.1.

I'm comfortable closing this as outdated given that a known bug in the screenshotted version caused this error in this room. Post a broken saved game if you have one though and I'll confirm.

Note: See TracTickets for help on using tickets.