Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#11649 closed defect (fixed)

CINE: Operation Stealth Amiga US version not starting

Reported by: fxgogo Owned by: karisal
Priority: normal Component: Engine: Cine
Version: Keywords:
Cc: karisal Game: Operation Stealth

Description

Operation Stealth Amiga US version not starting and generating an error.
ERROR: Cannot open file errmess.dat for reading!
ScummVM version 2.1.3pre1-ge2a851b964
Host OS: Windows 10 64bit 1909 Build 18363.1016
Game version: English, USA, Amiga floppy

Bug details:
I have a folder with all three floppy disks from Amiga US version.
Create a new game in ScummVM. Point to the folder.
ScummVM recognises Amiga version. Not changes are made to settings.
Start the game, after warning of build version, I get the above error.

Attachments (4)

Disk3.jpg (678.4 KB ) - added by fxgogo 6 months ago.
Disk2.jpg (713.0 KB ) - added by fxgogo 6 months ago.
Disk1-2.jpg (643.7 KB ) - added by fxgogo 6 months ago.
Disk1-1.jpg (697.0 KB ) - added by fxgogo 6 months ago.

Change History (15)

in reply to:  description comment:1 by karisal, 6 months ago

Replying to fxgogo:

I have a folder with all three floppy disks from Amiga US version.

@fxgogoCould you please download md5deep from ​http://md5deep.sourceforge.net/
and then run the following in the directory where you have the game data files
for your version of Operation Stealth and give the output here into this ticket:

echo The listing of files:
dir
echo MD5sums of the first 5000 bytes of each file:
md5deep -p 5000 * | find /i "offset 0-4999"
echo MD5sums of the full files:
md5deep *

The idea is to get the file sizes and names using "dir" command,
the MD5sums of the files' first 5000 bytes by the second command and
the MD5sums of the whole files by the third command. Are you sure
there is no errmess.dat in any of the source floppies?

Thank you!

Version 0, edited 6 months ago by karisal (next)

comment:2 by karisal, 6 months ago

Cc: karisal added
Component: --Other--Engine: Cine

comment:3 by karisal, 6 months ago

Summary: Operation Stealth Amiga US version not startingCINE: Operation Stealth Amiga US version not starting

comment:4 by fxgogo, 6 months ago

D:\Games\ScummVM\Games\os> echo The listing of files:
The listing of files:

D:\Games\ScummVM\Games\os> dir

Volume in drive D is sid6502
Volume Serial Number is D2F8-F077

Directory of D:\Games\ScummVM\Games\os

31/08/2020 20:03 <DIR> .
31/08/2020 20:03 <DIR> ..
06/11/1990 16:38 58 .info
22/10/1990 17:57 2,196 add21k
30/10/1990 12:30 103,200 bond
22/10/1990 17:56 1,482 bond.info
22/10/1990 17:57 1,516 Bond_HD_Startup.info
10/10/1990 18:29 19 cli.start
30/10/1990 12:29 1,764 disk.info
22/10/1990 18:06 17,044 EgouBase
30/10/1990 12:36 18,758 LabyBase
29/01/2014 10:39 868,864 md5deep64.exe
22/10/1990 17:58 512 poldat.dat
06/11/1990 16:36 40,468 procs0
30/10/1990 12:36 60,742 ProcS1
30/10/1990 12:37 67,050 procs2
31/08/2020 17:07 <DIR> s
22/10/1990 17:56 59,254 samples
30/10/1990 12:37 96,224 Samples2
22/10/1990 18:06 96,491 Samples3
30/10/1990 12:35 96,810 Sd01A
30/10/1990 12:36 262,284 Sd01B
30/10/1990 12:36 66,048 Sd01C
30/10/1990 12:36 51,574 Sd01D
22/10/1990 18:06 537,822 sd02
22/10/1990 17:57 207,970 sd03
22/10/1990 17:56 175,712 Sdsons
30/10/1990 12:36 129,778 Sdsons2
22/10/1990 18:05 109,748 Sdsons3
06/11/1990 16:58 211,356 sintro2
22/10/1990 17:56 5,764 Texte.dat
22/10/1990 17:56 35 VOL.1
30/10/1990 12:36 57 VOL.2
22/10/1990 18:05 38 VOL.3
22/10/1990 17:56 3,884 VOL.CNF

32 File(s) 3,294,522 bytes

3 Dir(s) 157,889,990,656 bytes free

D:\Games\ScummVM\Games\os> echo MD5sums of the first 5000 bytes of each file:
MD5sums of the first 5000 bytes of each file:

D:\Games\ScummVM\Games\os> md5deep -p 5000 * | find /i "offset 0-4999"
'md5deep' is not recognized as an internal or external command,
operable program or batch file.

D:\Games\ScummVM\Games\os> echo MD5sums of the full files:
MD5sums of the full files:

D:\Games\ScummVM\Games\os> md5deep *
'md5deep' is not recognized as an internal or external command,
operable program or batch file.

D:\Games\ScummVM\Games\os>md5deep64 *
77bf87596f7f176656a4f2ab269851a1 D:\Games\ScummVM\Games\os\.info
4fb050940d8dbca55461c4bd64c845b5 D:\Games\ScummVM\Games\os\add21k
239422bf4b9ee2f1705929f45d21260e D:\Games\ScummVM\Games\os\bond
630f3164c3510a452997ca819820fb42 D:\Games\ScummVM\Games\os\bond.info
ee11b3dd706327bd2a7694f8b38e83e5 D:\Games\ScummVM\Games\os\Bond_HD_Startup.info
c88099b03cea90c2fc0fc2b3e8749d81 D:\Games\ScummVM\Games\os\cli.start
ee701563d27c595b29e309d979782477 D:\Games\ScummVM\Games\os\disk.info
8932f627148e6b7c9bc6d05a3d9f2dd3 D:\Games\ScummVM\Games\os\EgouBase
34adda82881811bc7ed1495ea74b3c59 D:\Games\ScummVM\Games\os\endcli
c568a72b62ba7c3d6eab5dc7755f9877 D:\Games\ScummVM\Games\os\LabyBase
f2b555e6826945993b481e7dfc59b99a D:\Games\ScummVM\Games\os\poldat.dat
31d15b7ea0c90ad97f7fd3e78e26271a D:\Games\ScummVM\Games\os\procs0
7643bfafa4ed6aa68dfadf177587c798 D:\Games\ScummVM\Games\os\ProcS1
D:\Games\ScummVM\Games\os\s: Is a directory
1d90637d5fcf5c09c59fc3fade0bc79b D:\Games\ScummVM\Games\os\md5deep64.exe
86a4de48fffc98ebd43cbcc621c6a1eb D:\Games\ScummVM\Games\os\procs2
dd5d695b1a70872f859fdfb14620ff85 D:\Games\ScummVM\Games\os\samples
0b62cbf16256461b47de4235049dfdea D:\Games\ScummVM\Games\os\Samples3
5356075cde469247319ad38fd16c8181 D:\Games\ScummVM\Games\os\Samples2
5e764fc8bc8dca7fb76dfe7a98ff99bb D:\Games\ScummVM\Games\os\Sd01A
60046e399388e0454ebfc06d2027bc4d D:\Games\ScummVM\Games\os\Sd01B
14948eb110d2e9519a5a4e4f103613d9 D:\Games\ScummVM\Games\os\Sd01C
231be7286b6b366d9cf707dc5e73b286 D:\Games\ScummVM\Games\os\Sd01D
59eda74e426b6efb16bd97d9c6655d91 D:\Games\ScummVM\Games\os\sd02
29d4d21f34876d4e89567a3cab75b7a2 D:\Games\ScummVM\Games\os\sd03
6f8356a5d5d91f9959ae16440ce87ab9 D:\Games\ScummVM\Games\os\Sdsons
9660c40966026818ea822c1151e0ba4d D:\Games\ScummVM\Games\os\Sdsons2
e99b6fa1613f2757d325f3a1784b92d4 D:\Games\ScummVM\Games\os\Sdsons3
3e6f5ff8cbf53d75457965c0dda2da4b D:\Games\ScummVM\Games\os\Texte.dat
e3e028cc628f787feb6de3697d9cb0c8 D:\Games\ScummVM\Games\os\sintro2
ba6eedb4279087ac47f90b36fdfc86d8 D:\Games\ScummVM\Games\os\VOL.1
e8409f3840de7db5ca7e197c1f7850e2 D:\Games\ScummVM\Games\os\VOL.2
e669ff8d991993f6a5abfb4ba915dfb7 D:\Games\ScummVM\Games\os\VOL.3
e56dc79ac1acbdbe4b51404400a272ab D:\Games\ScummVM\Games\os\VOL.CNF

D:\Games\ScummVM\Games\os>

I can go back to the floppies rather than the ADF's I made to double check.

comment:5 by fxgogo, 6 months ago

apologies, I saw the one command did not run. Here it is:

D:\Games\ScummVM\Games\os>md5deep64 -p 5000 * | find /i "offset 0-4999"
cf9ecd8818bffc2303f61be47b535aac D:\Games\ScummVM\Games\os\bond offset 0-4999
751f1b3d7af80d6c60f18f2b4f00cac6 D:\Games\ScummVM\Games\os\EgouBase offset 0-4999
0d173466f625877641ce001e0e8184b3 D:\Games\ScummVM\Games\os\LabyBase offset 0-4999
44f3f6d0b81f7ddb5d1e9a0d5de91231 D:\Games\ScummVM\Games\os\md5deep64.exe offset 0-4999
D:\Games\ScummVM\Games\os\s: Is a directory
d5f27e33fc29c879f36f15b86ccfa58c D:\Games\ScummVM\Games\os\procs0 offset 0-4999
ff60f9c83ebc95f68160933f9616ec07 D:\Games\ScummVM\Games\os\ProcS1 offset 0-4999
f247b965075f3de90aacb817029f250f D:\Games\ScummVM\Games\os\procs2 offset 0-4999
3403e38033df63d99f264379369fd27d D:\Games\ScummVM\Games\os\samples offset 0-4999
f48d1d076ab626dd2ed8fc874a00d0ea D:\Games\ScummVM\Games\os\Samples2 offset 0-4999
eafdd16a0c7edf087aa8fba853df557e D:\Games\ScummVM\Games\os\Samples3 offset 0-4999
c5c2f55b49f428825cbb0dae9b7b8431 D:\Games\ScummVM\Games\os\Sd01A offset 0-4999
a74df2154a9abb79c2f6f93a77e650d0 D:\Games\ScummVM\Games\os\Sd01B offset 0-4999
8625d5b5bdf1f6649eddeebc5488fdc2 D:\Games\ScummVM\Games\os\Sd01C offset 0-4999
f77a3c386ade87429d399013d5f08f95 D:\Games\ScummVM\Games\os\Sd01D offset 0-4999
721ef3b72841772b4da15219effbc7c0 D:\Games\ScummVM\Games\os\sd02 offset 0-4999
1960b4fceb7d777894a2a69314ea494c D:\Games\ScummVM\Games\os\sd03 offset 0-4999
feb5bf20c00330fb8c3794234028a9e4 D:\Games\ScummVM\Games\os\Sdsons offset 0-4999
38a7fb93288a99a602e99a0b2f4a5324 D:\Games\ScummVM\Games\os\Sdsons2 offset 0-4999
e8562026cd9f4d7e88fe6c5a7e9e69b7 D:\Games\ScummVM\Games\os\Sdsons3 offset 0-4999
43fb9ce4800d4a58a718d439af3cda61 D:\Games\ScummVM\Games\os\sintro2 offset 0-4999
101969a12bd2e4f5504219a355848904 D:\Games\ScummVM\Games\os\Texte.dat offset 0-4999

in reply to:  4 comment:6 by karisal, 6 months ago

Replying to fxgogo:

I can go back to the floppies rather than the ADF's I made to double check.

Thanks for the file information you provided. It would be good to know if errmess.dat exists on the floppies or not. All the errmess.dat files that I've come across in different Operation Stealth versions are 1440 bytes in size.

Here are some MD5sums of errmess.dat files I've seen:
230abf113fcd9df6f466b4c138dfb687 German release
6b3b7099f48c561065afbac7a42d446d US release (Protagonist is named James Bond)
ab02342d5b89b1a3998eb32f2eca112a English release (Protagonist is named John Glames)
c82b927fa7c7a5604fa9dc297bcf6794 French release

You can even try to open files near the size 1440 bytes in a text editor to see if it contains text. The errmess.dat is a file containing text (With lots of trailing zeroes in between strings) like for an example:

You haven't noticed anything special.
Nothing interesting.
Nothing to say about it.
You find nothing.
Let's forget about it.
I could if I wanted, but I don't.
There are so many things to take and you want this one!
No need.
...

comment:7 by karisal, 6 months ago

Waiting for this pull request to be merged. If it is merged it would make Operation Stealth work even without the ERRMESS.DAT file by using default error messages as a fallback. Let's see...

in reply to:  7 comment:8 by karisal, 6 months ago

Replying to karisal:

Waiting for this pull request to be merged. If it is merged it would make Operation Stealth work even without the ERRMESS.DAT file by using default error messages as a fallback. Let's see...

The pull request was merged. Now your version should start and the error messages should be ok even without the ERRMESS.DAT. If you have it, great, if you don't, it'll fall back to the default error messages that are now included in the ScummVM's source code.

comment:9 by karisal, 6 months ago

Owner: set to karisal
Resolution: fixed
Status: newclosed

I'm closing this ticket as fixed because the problem is gone. @fxgogo If you happen to check out your original floppies would you please leave a comment here whether errmess.dat or some other 1440 bytes sized file exists on them? But if you don't, no worries, it should work without it now anyway.

by fxgogo, 6 months ago

Attachment: Disk3.jpg added

by fxgogo, 6 months ago

Attachment: Disk2.jpg added

by fxgogo, 6 months ago

Attachment: Disk1-2.jpg added

by fxgogo, 6 months ago

Attachment: Disk1-1.jpg added

comment:10 by fxgogo, 6 months ago

Hi Karisal, so I can confirm the game is working now. I will start playing it properly to check for bugs now. I have also attached the disk contents as jpgs. They come directly from my Amiga 1200.

in reply to:  10 comment:11 by karisal, 6 months ago

Replying to fxgogo:

Hi Karisal, so I can confirm the game is working now. I will start playing it properly to check for bugs now. I have also attached the disk contents as jpgs. They come directly from my Amiga 1200.

Ok, thanks for the info! It looks like errmess.dat is not on the original floppies. But, it works without it now so it's ok.

Note: See TracTickets for help on using tickets.