Opened 14 months ago

Last modified 2 months ago

#11636 new defect

ILLUSIONS: Duckman: Subtitle timing is too fast to read

Reported by: meunierd Owned by: sev-
Priority: normal Component: Engine: Illusions
Version: Keywords:
Cc: Game:

Description

A set of lines will flash by in quick succession well before the dialogue has caught up. This is using version 74f7a17d on MacOS.

Change History (13)

comment:1 by sev-, 14 months ago

Could you please elaborate a bit? Where does it happen? Do you have a savegame? What are the steps to reproduce?

comment:2 by meunierd, 14 months ago

I've recorded repro video here: https://youtu.be/qhfEhENqyMc

It happens for all subtitled dialogue in-game, starting from the very beginning. Here you can see it once Cornfed starts talking. No save file is necessary, it starts at the beginning of a New Game.

comment:3 by sev-, 14 months ago

Priority: normalhigh

comment:4 by sev-, 14 months ago

Summary: Duckman: Subtitle timing is too fast to readILLUSIONS: Duckman: Subtitle timing is too fast to read

comment:5 by raziel-, 14 months ago

Same problem on AmigaOS4.

It seems as if the subtitles are simply displayed without any delay between the lines.
I guess they go by even faster on strong machines.
I can read them but am not able to catch any details.
It goes by much to fast and is completely out of sync to the spoken lines.

comment:6 by sev-, 14 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

I fixed it, there was a mistake in disassembly.

However, I noticed that the subtitles match the text length (roughly) only when their speed is set to max.

comment:7 by meunierd, 14 months ago

I just tried on a36c20c8 and am still able to reproduce this issue.

comment:8 by sev-, 14 months ago

Did you change the subtitle speed to max in-game?

comment:9 by raziel-, 14 months ago

@sev-

I did not.
If the default setting is not broken in any way I'm using that.
Just added the game and started it right away (back when I tried it)

comment:10 by meunierd, 14 months ago

What I'm noticing is that the text speed setting is a different value than all other settings, but if you manually adjust it to where the others are, it seems fine. Maybe the default value isn't initializing correctly?

comment:11 by raziel-, 13 months ago

My default (global) subtitle speed setting is 60.

comment:12 by raziel-, 4 months ago

Resolution: fixed
Status: closednew

ScummVM 2.3.0git (Jul 3 2021 01:39:11)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) TinyGL OpenGL

With todays build and the textwidth fix for BE platforms from #11528 this issue is still present.
Subtitles goes by too fast, not in snyc with the dialog.

subtitles are set to "false" globally here
talkspeed is set to 60 in the duckman settings

Maybe because of the global subtitles setting to off, it picks up the wrong (or any) value and thus displays them too fast.
I also think that there is a second bug here, because the subtitles shouldn't be displayed et al due to the global setting.

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 11.1.0) 11.1.0

comment:13 by sev-, 2 months ago

Priority: highnormal
Note: See TracTickets for help on using tickets.