Opened 3 months ago

Closed 3 months ago

#11635 closed defect (fixed)

ANDROID: Backend failed to instantiate event manager

Reported by: bgK Owned by: ccawley2011
Priority: blocker Component: Port: Android
Keywords: Cc: ccawley2011
Game:

Description

With the current git master - 3f45f772699dde897bb719f9263f3e5220fdda3b, ScummVM fails to start on Android with the error Backend failed to instantiate event manager!. This seems to have been caused by this commit:

commit 7745ffdac1ccae59471e24eaeb1b081ea8fceecd
Author: Cameron Cawley <ccawley2011@gmail.com>
Date:   Sun Aug 2 21:07:58 2020 +0100

    BACKENDS: Simplify EventsBaseBackend

Change History (3)

comment:1 by bgK, 3 months ago

Looking more closely at this commit, why does EventsBaseBackend need to virtually inherit from BaseBackend, forcing the use of dynamic_cast where it should not be needed?

comment:2 by ccawley2011, 3 months ago

Cc: ccawley2011 added
Priority: normalblocker

I added virtual inheritance to EventsBaseBackend so it can be used alongside ModularGraphicsBackend, ModularMutexBackend and ModularMixerBackend, but it looks like I forgot to actually make OSystem_Android inherit from EventsBaseBackend. Will fix this shortly.

comment:3 by ccawley2011, 3 months ago

Owner: set to ccawley2011
Resolution: fixed
Status: newclosed

This is fixed in commit 2cdbc27ef862a2f0aa7a6dc29fa5d7ccfb0c661a.

Note: See TracTickets for help on using tickets.