Opened 3 months ago

Closed 3 months ago

#11628 closed defect (fixed)

Blazing Dragons: Intro has artifacts

Reported by: afreickmann Owned by: yuv422
Priority: normal Component: Engine: Dragons
Keywords: Cc:
Game: Blazing Dragons

Description (last modified by afreickmann)

During the start of the game the Intro sequence is not correctly playing and has artifacts on black backgrounds. Also the sound has issues. Please see the video as reference: https://youtu.be/97u1aujPJ9c

I compared it to version ScummVM 2.2.0git8427-gb438f6fb07, this version does not have the issue.

Blazing Dragons US
ScummVM: ScummVM 2.2.0git8548-gc77bb2984a
OS: Windows

Change History (2)

comment:1 by afreickmann, 3 months ago

Description: modified (diff)

comment:2 by yuv422, 3 months ago

Owner: set to yuv422
Resolution: fixed
Status: newclosed

This was caused by changing the underlying colour format to enable open GL rendering. I've fixed it by blanking the background before rendering each new frame.

Note: See TracTickets for help on using tickets.