Opened 3 months ago

Closed 3 months ago

#11620 closed defect (fixed)

SCI: SQ5 pausing WD-40's script in Genetix Dome and disabling exits

Reported by: Bill-Bull Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Space Quest 5

Description

In Genetix Dome, after returning Roger to his body, when you walk across the bridge going from the starting screen (pic.110 in SCI Companion) going to the secret lab (pic.112 in SCI Companion), there is a brief period of time where you regain control of the mouse cursor while the screen is in transition. You can then click to move Roger on the new screen, interrupting WD-40's scheduled appearance and preventing you from leaving.

I can confirm this can happen in Sierra's interpreter, as well, using DOSBox.

This is likely a similar bug to #11605.

*ScummVM versioninfo=2.2.0git8444-g7521cc5f9e
*DOS/English version of the game
*Save game is attached. To replicate, walk Roger left over the bridge and continue clicking while the screen transitions.

Attachments (1)

sq5.018 (43.4 KB ) - added by Bill-Bull 3 months ago.

Download all attachments as: .zip

Change History (4)

by Bill-Bull, 3 months ago

Attachment: sq5.018 added

comment:1 by Bill-Bull, 3 months ago

Component: --Unset--Engine: SCI
Game: Space Quest 5

comment:2 by sluicebox, 3 months ago

Another great find! This is a game breaking bug if you don't already have the hole punch since you won't be able to leave the room. A similar thing happens when doing this after the WD-40 scene; the exits don't work. The script for entering from the bridge as a human is missing the necessary handsOff call that everyone else has.

I have a patch, I'll get it written up and committed soon.

Last edited 3 months ago by sluicebox (previous) (diff)

comment:3 by sluicebox, 3 months ago

Keywords: original added
Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.