Opened 2 years ago

Closed 9 months ago

#11604 closed defect (wontfix)

ULTIMA 8: scalers do not change the game pixels

Reported by: DominusExult Owned by: mduggan
Priority: normal Component: Engine: Ultima
Version: Keywords:
Cc: Game: Ultima VIII: Pagan

Description

Changing the scaler does only enlarge the game but does not apply the pixel changes

Change History (5)

comment:1 by mduggan, 2 years ago

Hi @DominusExult, thanks for the report.

I just tried with HQ3x and SuperEagle on the latest code and they both worked ok me.
Could you send more details on which settings you were trying?

comment:2 by DominusExult, 2 years ago

Figured it out. my fault for not using lockstock settings.

The problem only occurs when you set width/height in the Ultima 8 section of the ScummVM settings file.
I experimented with this when I tried to figure out why the bigger view is not working (actually scalex/scaley but that's in another bug report). As you can just enlarge the ScummVM window and retain scaling, you might want to close this as "won't fix" or get rid of reading these settings (width/height).

comment:3 by mduggan, 2 years ago

Owner: set to mduggan
Resolution: pending
Status: newpending

Thanks for checking. I probably should remove support for those settings as they just cause unexpected behaviour. I'll leave this open to do that, but it's less urgent than it not working at all at least :)

comment:4 by sev-, 20 months ago

Resolution: pending
Status: pendingnew

comment:5 by mduggan, 9 months ago

Resolution: wontfix
Status: newclosed

I might just leave these settings as supported, there is now an accessible "wide screen" option and the scalers should be ok.

Note: See TracTickets for help on using tickets.