Opened 3 months ago

Closed 3 months ago

#11589 closed defect (fixed)

Blazing Dragons: Crash at Stonehenge Rescue Knights scene

Reported by: afreickmann Owned by: yuv422
Priority: blocker Component: Engine: Dragons
Keywords: Cc:
Game:

Description

The game has a game stopping bug at the rescue of the knights scene at the Stonehenge trap. It is expected to give paddles to the knights, so that they can free themselves. This is happening in an extra animated close up, which likely can't be found and thus crashing ScummVM.

See the scene in the original game (https://youtu.be/lYPBQBJxuT0?t=6089). You can reproduce the bug with the attached savegame.

Debuglog:
[2020-08-23 15:55:23] actor 4 Init
[2020-08-23 15:55:23] execScriptOpcode(0x1F) @0 opPlayMusic
[2020-08-23 15:55:23] ARG_INT16(songNumber = 17)
[2020-08-23 15:55:23] Load music file s10dz17.msq
[2020-08-23 15:55:23] Invalid resourceID for input filename: s10dz17.msq!

Blazing Dragons US
ScummVM: 2.2.0git8408-g60225edf42
OS: Windows

Attachments (1)

dragons-us.015 (13.4 KB ) - added by afreickmann 3 months ago.

Download all attachments as: .zip

Change History (3)

by afreickmann, 3 months ago

Attachment: dragons-us.015 added

comment:1 by yuv422, 3 months ago

I've just committed a fix for this issue. It looks like there is no music file associated with this cut scene. I've changed the logic to skip the music load in this case.

comment:2 by yuv422, 3 months ago

Owner: set to yuv422
Resolution: fixed
Status: newclosed

This should be fixed now.

Note: See TracTickets for help on using tickets.