Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#11578 closed defect (fixed)

Blazing Dragons: Wrong sounds during intro cutscene (or bad data files?)

Reported by: eriktorbjorn Owned by: yuv422
Priority: normal Component: Engine: Dragons
Keywords: Cc:
Game:

Description

(I can't find the engine or the game in the dropdowns, so I'll file this as "--Other--" for now)

Using the GB Playstation version, in the opening cutscene (where they they discuss the raid) the game plays the same sound effect for every (?) background sound.

It may just be that particular scene, though. Once the alarm clock starts it seems to work. (That's as far as I've played it, though.)

It looks like the problem is that when it loads the sounds for the scene (loadToneAttributes()), while it says it's loading 16 of them, only the first one has any data. So when getAudioStream() looks up the sound, it doesn't find any and vagID remains 0.

So is this a problem with the game engine, or did I mess up when extracting the files from the disc? It seems strange that a damaged file would be so specific, and not just wreck the entire game but...

Change History (4)

comment:1 by sev-, 3 months ago

Component: --Other--Engine: Dragons

comment:2 by yuv422, 3 months ago

I think the problem here is that this scene uses a single sound sample but at different pitches. I need add some logic to shift the pitch if there isn't already a tone at the desired pitch

comment:3 by yuv422, 3 months ago

Owner: set to yuv422
Resolution: fixed
Status: newclosed

Ok so it turns out that the sfx are missing in the playStation version. I checked with several emulators. I guess the devs must have forgotten to include those sfx in the scene file.

They are present in the SEGA Saturn version though. :)

I've modified the engine to only play a sfx if it can find a tone that matches the sfx key.

comment:4 by eriktorbjorn, 3 months ago

Sounds like a good reason to support the SEGA version later. :-)

Note: See TracTickets for help on using tickets.