Opened 16 years ago

Closed 16 years ago

#1157 closed defect (fixed)

MI1: SFX crash regression with native midi

Reported by: SF/logicdeluxe Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

ScummVM 0.5.3cvs (Aug 15 2003 21:25:49)
Using native midi.
Whenever I (or the citizens of melee) try to open a
door, ScummVM shuts down with "Fatal signal:
Segmentation Fault (SDL Parachute Deployed)". The same
happens when climbing the steps to the cable to meat
hook's, so it seems to be related to sound effects in
general.
It happens with EGA and VGA floppies. This does not
happen with '-eadlib'. This worked when native midi was
implemented recently to those games.

Ticket imported from: #789278. Ticket imported from: bugs/1157.

Change History (4)

comment:1 by Kirben, 16 years ago

My fault, try latest ScummVM cvs or Windows snapshot now
to see if this fix works.

comment:2 by Kirben, 16 years ago

Owner: set to Kirben

comment:3 by SF/logicdeluxe, 16 years ago

Okay, it works again.

comment:4 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.