Opened 14 months ago

Closed 4 months ago

#11568 closed defect (fixed)

WME: Rhiannon - Animated background objects are pink blobs

Reported by: raziel- Owned by: lolbot-iichan
Priority: normal Component: Engine: Wintermute
Version: Keywords: has-pull-request, regression
Cc: Game: Wintermute

Description

ScummVM 2.2.0git (Aug 19 2020 10:53:01)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC A/52 FreeType2 FriBiDi JPEG PNG cloud (servers, local)

This is a regression.
All animated background objects (there aren't that many in the game) appear as solid pink blobs (most prominent in the very first scene in front of the house).
There should be an animated pond with waves visible, instead there is a pink blob (see attached screenshot)

Rhiannon: Curse of the four Branches (DVD/Windows/English)

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 8.3.0) 8.3.0

Attachments (1)

Rhiannon_ Curse of the four Br_000.png (640.1 KB ) - added by raziel- 14 months ago.

Download all attachments as: .zip

Change History (2)

comment:1 by lolbot-iichan, 4 months ago

Keywords: has-pull-request added
Owner: set to lolbot-iichan
Resolution: fixed
Status: newclosed

I finally fixed it with https://github.com/scummvm/scummvm/pull/3126
Please, check the nightly build.

P.S. It was partially a regression, partially an old bug - I have checked with 2.0.0 and some blobs were pink, not transparent back then. It's because Rhiannon mostly use 24 bit PNGs, but fome backgrounds were 32 bit PNGs with pink areas, which should be transparent at WME 1.x, but should NOT be transparent in WME Lite. Since ScummVM implementation is WME Lite based, this bug was present earlier. Since today's nightly build, ScummVM tries to emulate different colorkey behaviour for WME 1.x and WME Lite games.

Note: See TracTickets for help on using tickets.