Opened 4 months ago

Closed 2 months ago

Last modified 2 months ago

#11554 closed defect (worksforme)

BACKENDS: MacOSX - Adding EcoQuest 1 (CD-ROM) to daily build - exception crash

Reported by: Purduecoz Owned by: criezy
Priority: normal Component: Port: Mac OS X
Keywords: crash macos ecoquest eco1 Cc:
Game: EcoQuest 1

Description (last modified by Purduecoz)

Using the August 5th daily build for MacOS, adding the English CD-ROM version of EcoQuest 1 results in a ScummVM crash with the following problem report. This occurs every time. I'm using MacOS 10.15.5 but this has been occurring on previous MacOS versions too. The same version of the game is able to be added to the Windows daily build without incident, so I am fairly confident that the game files are correct. Please let me know what else I can provide to help troubleshoot.

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [48903]

Change History (10)

comment:1 by Purduecoz, 4 months ago

Description: modified (diff)

comment:2 by Purduecoz, 4 months ago

Summary: Adding EcoQuest 1 CD-ROM to MacOS Daily build - exception crashMACOS: Adding EcoQuest 1 CD-ROM to MacOS Daily build - exception crash

comment:3 by criezy, 4 months ago

This is a strange one, and I cannot reproduce it.

I tried adding the EcoQuest 1 English CD version using 4 different versions of ScummVM on 2 different macs, and I it worked in all cases for me.

Does it crash just after you select the folder with the game data files? Or do you get the dialog asking if you want to add the DOS or Windows version and it crash after that?

Maybe your ScummVM Preferences file (~/Library/Preferences/ScummVM Preferences) is corrupted? You could try to move it out of the day to check if that is the issue.

You could also try adding the games on the command line using Terminal.app to see if it works. For example if ScummVM is in the Applications folder, and Eco Quest is in your Documents folder, it would look like this:

iMac:~ criezy$ /Applications/ScummVM.app/Contents/MacOS/scummvm --add -p ~/Documents/EcoQuest1/
Game Added: 
  Target:   ecoquest-cd
  GameID:   sci:ecoquest
  Name:     EcoQuest: The Search for Cetus (CD/DOS/English)
  Language: English
  Platform: DOS
Game Added: 
  Target:   ecoquest-cd-win
  GameID:   sci:ecoquest
  Name:     EcoQuest: The Search for Cetus (CD/Windows/English)
  Language: English
  Platform: Windows
Added 2 games

Note: you can Drag and Drop the ScummVM.app and the EcoQuest folders on the Terminal window to get the path to those instead of typing it.

Versions I tried:

  • The 2.1.2 official release
  • The latest 32 bit daily build (osx_intel-master-ac1fb79d)
  • The latest 64 bit daily build (osx_x64-master-ac1fb79d)
  • My own compilation with the latest code (b0a56a0)

I tried on both macOS 10.12.6 and macOS 10.15.5 (although obviously I could not try the 32 bit daily build on macOS 10.15.5 since it cannot run 32 bit applications).

comment:4 by Purduecoz, 4 months ago

It crashed right after I selected the folder; no dialog boxes. I’ll give your suggestions a shot and see if I can get some more detail or get different results. It does help to know you couldn’t reproduce and I do have another Mac that I can try. Thank you!

comment:5 by Purduecoz, 4 months ago

Interesting. Still crashing even on a brand new 10.15.6 MacOS MacBook Air that has only ever seen the latest daily build installed (no existing games). I tried manually adding the game using the command line that you suggested, and they did add properly - though I also got a warning too:

2020-08-11 12:12:07.044 scummvm[1399:64660] NSDocumentController Info.plist warning: The values of CFBundleTypeRole entries must be 'Editor', 'Viewer', 'None', or 'Shell'.
Game Added:

Target: ecoquest-cd
GameID: sci:ecoquest
Name: EcoQuest: The Search for Cetus (CD/DOS/English)
Language: English
Platform: DOS

Game Added:

Target: ecoquest-cd-win
GameID: sci:ecoquest
Name: EcoQuest: The Search for Cetus (CD/Windows/English)
Language: English
Platform: Windows

Added 2 games

comment:6 by raziel-, 4 months ago

Summary: MACOS: Adding EcoQuest 1 CD-ROM to MacOS Daily build - exception crashBACKENDS: MacOSX - Adding EcoQuest 1 (CD-ROM) to daily build - exception crash

comment:7 by sev-, 3 months ago

Priority: highnormal

comment:8 by criezy, 3 months ago

Something else you could try is to go into the ScummVM Options, and in the Misc tab toggle off the "Use native system file browser" option, and then try to add the game again. If that solves the crash then it would suggest that the issue is with the native macOS file browser.

A few users have reported issues with the application freezing after they select a game to add using the native macOS file browser in ScummVM (for example here and here), so I know there is something wrong with the code, but I never managed to find the issue or consistently reproduce it.

comment:9 by Purduecoz, 2 months ago

This is now working for me with Scummvm 2.2.0. No other changes. I guess we can close and just chalk it up as a mystery!

Last edited 2 months ago by Purduecoz (previous) (diff)

comment:10 by criezy, 2 months ago

Owner: set to criezy
Resolution: worksforme
Status: newclosed

Thanks for the update. That is indeed a mystery, but it's good that it works for you now.
I will close this as worksforme since I was not able to reproduce it even with an older version of ScummVM.

Note: See TracTickets for help on using tickets.