Opened 4 years ago

Closed 18 months ago

#11507 closed defect (fixed)

BACKENDS: Windows - Alt + F5 no longer brings up original menus in Lucasarts games

Reported by: neilalphazeta Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game:

Description

As of 2.1.1 (perhaps earlier) the original menus no longer can be brought up by pressing alt + F5 in Lucasarts games. Using Windows 10 / 64 bit.

Change History (6)

comment:1 by neilalphazeta, 4 years ago

Component: --Unset--Engine: SCUMM

comment:2 by criezy, 4 years ago

neilalphazeta, can you indicate which games you tested in case this does not happen with all SCUMM games. Also if you have the time it would be interesting to test with older versions to find which one introduced the issue. Older releases can be found in https://www.scummvm.org/frs/scummvm/.

This is related to bug #11504, but may be a different issue specific to Windows on top of it.

The issue described in bug #11504 does not occur in any of the 2.1.x release as it was introduced by a commit that is more recent (and I tested on macOS that accessing the original SCUMM menus does work properly in 2.1.1).

It would be good for a developer that has access to Windows to confirm that the issue indeed exists in 2.1.1 on that OS, and that there is thus another bug in addition to #11504.

comment:3 by neilalphazeta, 4 years ago

Hello Criezy,

So I tried going as far back as possible and no matter what version I tried it wasn't working. I was wondering if it was just a problem with my PC so I went to another PC (in this case a Windows 7 / 64 bit) and tried downloading them there. I went as far back as 1.2.0 and could still not get alt F5 to work on any Lucasarts games. I tried in many games from Fate of Atlantis all the way to The Dig.

I even checked the unicode settings and everything was set to English, so I don't think that was the problem.

Is it possible that the Windows versions have had this feature broken for that long a time?

comment:4 by raziel-, 4 years ago

Summary: WINDOWS: Alt + F5 no longer brings up original menus in lucasarts gamesBACKENDS: Windows - Alt + F5 no longer brings up original menus in Lucasarts games

comment:5 by tag2015, 18 months ago

I think the Alt-F5 combination is no longer used?
With the recent implementation of the original menus for all scumm games, the behavior is the following:

  • If the option "enable original gui and menus" is enabled, F5 opens the original menu, while CTRL-F5 opens the GMM,
  • If the option is disabled, both F5 or CTRL-F5 open the GMM.

I haven't followed the keymapper discussion at the time, but at least on my system (Win10) everything works normally now.

comment:6 by criezy, 18 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

Indeed, the Alt-F5 combination has been replaced by an engine option. So whether there was a Windows-specific issue on top of #11504 or not, this should no longer matter, and this issue is very likely to have been fixed now.

Note: See TracTickets for help on using tickets.