Opened 4 years ago

Closed 16 months ago

#11500 closed defect (worksforme)

GUI: Pressing escape in the GTK file chooser sometimes closes ScummVM

Reported by: bgK Owned by: lotharsm
Priority: normal Component: GUI
Version: Keywords:
Cc: Game:

Description

ScummVM 480d7fddbe4a217e1733fee7588be93fa95504d6 on Linux/X11 with GTK 3.24.20.

When pressing the Add Game button in the launcher with the Use native file browser option checked, the GTK file chooser opens as expected. When pressing escape to close the file chooser, the file chooser closes. Most of the time ScummVM closes as well. Maybe ScummVM receives the key press event that was meant to be handled by the file chooser?

I've also noticed that when opening the GTK file browser for the second time, the window opens below the ScummVM window.

Change History (4)

comment:1 by lotharsm, 2 years ago

Priority: normalhigh

comment:2 by eriktorbjorn, 23 months ago

I can't reproduce either of these, running Linux/X11 and GTK+ 3.24.34.

Could it also be dependent on desktop environment? I'm using Xfce.

comment:3 by lotharsm, 16 months ago

I tried to reproduce it on Ubuntu 22.04 using Wayland and ScummVM 2.8.0 - I couldn't trigger this issue as well. I'm using GNOME 42.5.

comment:4 by lotharsm, 16 months ago

Owner: set to lotharsm
Priority: highnormal
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.