Opened 4 years ago

Last modified 8 months ago

#11483 new defect

ZVISION: ZGI: Music broke

Reported by: vocaab Owned by:
Priority: high Component: Engine: ZVision
Version: Keywords: Zork, Grand Inquisitor, Music
Cc: Game: Zork Grand Inquisitor

Description

Hi, I'm playing the gog release of Zork Grand Inquisitor, and the music stops playing completely, and never comes back. I have a save file I will upload that has the issue. This is with version 2.0

Attachments (1)

zgi-dvd.013 (24.0 KB ) - added by vocaab 4 years ago.

Download all attachments as: .zip

Change History (7)

by vocaab, 4 years ago

Attachment: zgi-dvd.013 added

comment:1 by vocaab, 4 years ago

Summary: Zork: Grand InquisitorZork: Grand Inquisitor Music broke

comment:2 by vocaab, 4 years ago

Component: --Unset--Engine: ZVision

comment:3 by sev-, 4 years ago

Priority: normalhigh
Summary: Zork: Grand Inquisitor Music brokeZVISION: ZGI: Music broke

comment:4 by eriktorbjorn, 3 years ago

I can't say I understand how ZGI handles music. There is a length script called universe.scr.txt that seems to have a lot to do with it.

If I open the debug console (Ctrl+Alt+D) and type "statevalue 14000 0" followed by "exit" to close the debug console, that seems to get the music started again. I don't know if it will stay working, or if it will get stuck again.

In the saved game, statevalue 14000 has the value 1 to begin with, but there are a dozen places where that could have happened.

comment:5 by NMIError, 3 years ago

When I load the savegame from the launcher, music does play. When I load the savegame from the in-game menus, there is no music. Strange...

comment:6 by sev-, 8 months ago

Would be nice to get fixed before 2.8.0 release

Note: See TracTickets for help on using tickets.