Opened 2 years ago

Closed 2 years ago

Last modified 22 months ago

#11478 closed defect (fixed)

ULTIMA6: Mouse unusable, no menu

Reported by: michas0602 Owned by: dreammaster
Priority: normal Component: Engine: Ultima
Version: Keywords: Ultima
Cc: Game: Ultima VI: The False Prophet

Description

ScummVM 2.2.0git (May 19 2020 17:53:10)

Mouse is unusable, it is very sluggish and constantly moves into one direction.

Furthermore I still have not found a button to return to the ScummVM-menu, can you please make all games more conformant (F5)?

German patched version of Ultima 6 is also not recognized/working.

Attachments (1)

Screencast from 25-05-2020 20:46:05.webm (738.1 KB ) - added by bgK 2 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 by michas0602, 2 years ago

Summary: Mouse unusable, no menuULTIMA 6: Mouse unusable, no menu

comment:2 by bgK, 2 years ago

Hi,

I can confirm the mouse cursor issue (or at least part of it). The mouse cursor is lagging behind the actual mouse position. See the attached video. I move the mouse over the ScummVM window for a while and then put it over the terminal. The cursor keeps moving in ScummVM for a while until it catches up with the actual mouse position.
From the looks of it, the engine does not consume the events from the event queue fast enough.

comment:3 by dreammaster, 2 years ago

Not sure how easy that will be to fix currently.. Nuvie implemented the menus and intros using the Lua interpreter, a scripting library that allows for scripts to be created and changed without requiring recompiling the main executable. I'll have to see where the event loop happens. Maybe a script change is possible to increase the responsiveness.

As for the menu, the key you want is Ctrl-F5 to bring up the ScummVM Global Main Menu. you can also press Escape in-game to get the game menu which has buttons for loading or saving games. I had originally hoped for allowing for F5/F7 for showing the save/load dialog, but in Ultima VI the function keys are used for opening the inventory of party members.

comment:4 by dreammaster, 2 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Summary: ULTIMA 6: Mouse unusable, no menuULTIMA6: Mouse unusable, no menu

I've changed the Lua script for the main menu to process events more rapidly, so improve the cursor smoothness. As for in-game, I can't map F5 to the menu or saving, because the original uses F5 as a shortcut key for opening the inventory of your fifth party member. But Ctl-F5 can still be used to open the GMM. As for the German version, I've previously added a detection entry for it. Though there are still parts of the user interface that aren't translated, because the German translation relied on hacking the original game executable to change the text strings, and with ScummVM replacing it, we'll need to do similarly at some point to add in translation for the UI elements

comment:5 by michas0602, 22 months ago

Hi, sorry for the late reply -
I recently tried it again with a wireless mouse - its better, unfortunately still not playable in my opinion, mouse is very sluggish.

Everything else seems fine - "my" patched german version is recognised now, menus and so on are top....beside the sluggish mouse.

Ah, and the intro-sequence was very small contrary to the game itself but I am currently not sure if I set the graphical options correct to "fit to window" or sth similar...but thats not so important as a perfect mousecontrol in my opinion.

I can try it later today with a different mouse - but all other games in ScummVM work good with my wireless-one.

Version 0, edited 22 months ago by michas0602 (next)
Note: See TracTickets for help on using tickets.