Opened 2 weeks ago

Closed 10 days ago

#11476 closed defect (fixed)

QFG1: Incomplete Music

Reported by: Deledrius Owned by: athrxx
Priority: normal Component: Audio: MT32
Keywords: mt-32, qfg1, qfg1ega Cc: Deledrius
Game: Quest for Glory 1

Description

Some music queues appear to be missing when playing QfG1 (EGA) in Emulated MT-32 mode on the current version of ScummVM. I noticed they played correctly on an older daily build (2.1.0git4992-g1b333ea19a March 25 2019) but do not work on the 2.1.0 release or newer, so this would seem to be a regression.

This can be easily tested right from the start of the game by entering Zara's Magic Shop: the music should start quite loudly and jarringly. Instead, only some very low quiet instruments play after a long delay. Another instance available at the start of the game is Brauggi's music, which only plays the beginning but not the coda.

Running git bisect, I found that 037eec31446b64ec56b24e31d5be392390a694ba is the first bad commit.

To ease testing, I have attached a saved game immediately outside the Magic Shop. Just enter and listen for music (or silence).

Attachments (1)

qfg1.001 (12.9 KB ) - added by Deledrius 2 weeks ago.
QfG1 EGA Saved Game - Outside Magic Shop

Download all attachments as: .zip

Change History (8)

by Deledrius, 2 weeks ago

Attachment: qfg1.001 added

QfG1 EGA Saved Game - Outside Magic Shop

comment:1 by Deledrius, 2 weeks ago

I'm not sure if this is the result of the same bug, but I also noticed that the music in Adlib mode sounds wrong here as well. In the current release, the music seems to only be playing a single note at a time, whereas it plays chords in the 2.1.0git4992-g1b333ea19a build. Alas, I did not test this mode when performing the git bisect, only the MT-32 mode.

comment:2 by athrxx, 2 weeks ago

Thanks for your report. Is the issue limited to QFG? In that case I'd focus on that...

comment:3 by ZvikaZ, 2 weeks ago

Adlib issue solved now in https://github.com/scummvm/scummvm/pull/2262

EDIT
====
Too early, it's not fixed yet...

Last edited 2 weeks ago by ZvikaZ (previous) (diff)

comment:4 by athrxx, 2 weeks ago

This magic shop is an interesting test case. That sound would fail on most devices I tested (MT-32, AdLib, CMS, FB-01). It is the same underlying issue. I think I've tracked it down. My local attempt of a fix seems to work.

Just to make sure we're talking about the same issue. Could you please try to comment out line 581 in music.cpp

if (pSnd->status != kSoundPaused)

and tell me if that does it for you (this is not the actual complete fix, but should address the issue).

comment:5 by Deledrius, 2 weeks ago

Yes, both Zara's shop and Brauggi's song play correctly with that workaround in place.

comment:6 by athrxx, 2 weeks ago

Thanks for testing! I don't even know what Brauggi's song is, since I've never played the game ;-).

I'll do some checkups with some other interpreter versions and commit a fix shortly.

comment:7 by athrxx, 10 days ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed

I close this, since the fix has been merged and you have confirmed it to be working on GitHub.

Note: See TracTickets for help on using tickets.