Opened 7 months ago

Closed 3 months ago

#11473 closed defect (worksforme)

ZVISION: ZGI Crashes Using Vacuum

Reported by: thejharvey Owned by: bluegr
Priority: normal Component: Engine: ZVision
Keywords: Cc:
Game: Zork Grand Inquisitor

Description

When opening the vacuum after getting the Zork rocks candy, ScummVM crashes. It is easily repeatable.

ScummVM version 2.1.2 (March 30, 2020)

This is part of the crash report:

System Integrity Protection: enabled

Notes: Translocated Process

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000111c2d000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [4284]

Attachments (1)

ZGI.003 (19.1 KB ) - added by digitall 6 months ago.

Download all attachments as: .zip

Change History (4)

comment:1 by digitall, 6 months ago

Component: --Unset--Engine: ZVision
Keywords: Zork Grand Inquisitor vacuum rocks suck removed
Summary: Zork Grand Inquisitor crashes when using vacuumZVISION: ZGI Crashes Using Vacuum

Thanks for this bug report. Can you please indicate your operating system, exact version of ScummVM etc.? I assume you are using the latest nightly build on OSX, but exact what version of OSX and what build is useful...

Also, please attach a savegame or otherwise steps to replicate this bug in the game...

comment:2 by digitall, 6 months ago

thejharvey responded on the mailing list as:

Mac OSX 10.15.4
Scumm 2.1.2

It’s crashes as soon as I use the vacuum on the vending machine and open the vacuum door. I’ve attached the save game file.

Thank you!

by digitall, 6 months ago

Attachment: ZGI.003 added

comment:3 by bluegr, 3 months ago

Owner: set to bluegr
Resolution: worksforme
Status: newclosed

I've tried it with the CD, DVD and GoG versions of ZGI. I can't reproduce the issue.

Steps I tried, from your saved game:

  • Inserted a Zorkmid in the vending machine
  • Pressed 8 for a Zork Rocks candy (which gets stuck)
  • Turned on the PermaSuck vacuum (a video starts)
  • Opened the vacuum door, got the candy, placed it in the inventory

It seems that the problem is related to corrupted game data files. Please copy them from your original media, or install the game again via the installer if you bought it off GoG.

Closing

Note: See TracTickets for help on using tickets.