Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1147 closed defect (fixed)

MI2: win game cheat on cursor key

Reported by: SF/logicdeluxe Owned by: SF/khalek
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

ScummVM 0.5.3cvs (Aug 12 2003 01:09:43)
Using Windows and a German MF2 keyboard with 105 keys.
(Key Tronic)
That "Are you sure you want to win? (Y/N)" also appears
when the cursor up key is pressed.
It can be easily reproduced anywhere, where you can pop
this up with alt-w as well, just by pressing cursor up.
I checked it with German and English version and it
happens with both.

Ticket imported from: #786995. Ticket imported from: bugs/1147.

Change History (3)

comment:1 by SF/quietust, 16 years ago

I'm getting the same thing on a standard English keyboard.

comment:2 by SF/khalek, 16 years ago

This is due to the fact monkey2 is looking for the same
scancode as what the up arrow is. (we convert alt+w to the
code its after)

For the time being CVS won't pass any arrow keys onto the
game, this will change when I am soon to either remove the
keyboard cursor control stuff or make it non default as it
breaks several things that I know of.

As mentioned above, this should be now fixed in CVS, closing

comment:3 by SF/khalek, 16 years ago

Owner: set to SF/khalek
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.