Opened 5 months ago

Closed 4 months ago

#11460 closed defect (invalid)

QFG1 VGA: can't knock on healer's door

Reported by: tomasz89 Owned by: tomasz89
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 1

Description

I haven't stolen anything! :)

I'm running ScummVM 2.2.0git4897-g62adf445b1 on Ubuntu 20.04 64 bit. The edition of QFG1 is from the Anthology edition.

When I go to enter the healer's hut, I never see the dialog box open to say I knock on the door - it just sticks.. forever.

I've seen this very occasionally in the DOS version, however have never been able to reliably reproduce. The save enclosed however does it for me 100%. Character walks over to the door OK, but the "You politely knock .." message never appears. Exiting the game seems to lock up ScummVM also; I have to kill -9 it despite having exited the game.

Attachments (1)

qfg1vga-1.019 (37.6 KB ) - added by tomasz89 5 months ago.

Download all attachments as: .zip

Change History (7)

by tomasz89, 5 months ago

Attachment: qfg1vga-1.019 added

comment:1 by m-kiewitz, 5 months ago

Summary: QFG1 can't knock on healer's doorQFG1 VGA: can't knock on healer's door

comment:2 by sluicebox, 5 months ago

I dunno... that's just what I'd expect an unscrupulous thief would say...

It's working for me on Win7x64 with the latest build using your save and the anthology version.

Are you hearing the knock-knock-knock sound at the door? The game script plays the knock sound three times and waits until each has completed. If there's something about your setup that's preventing that sound (sound 78) from playing then that could explain this.

Are you able to save the game when it gets stuck? If so, that save file would help figure out what's going on.

comment:3 by tomasz89, 4 months ago

Um I agree it works! I'm now on b96dabbaac643ae523e97ff5ff798c12a57c28fb.

I was not hearing the knock knock knock sound in this particular instance when I tried to visit the healer. Given the flow of the script, that would lead to a freeze. That said, this character in this play through had already visited the healer before and the knock sound had played just fine.

I've tried going to g62adf445b1 but it doesn't exist in the SCM history so can't revert to check this.

Last edited 4 months ago by tomasz89 (previous) (diff)

comment:4 by sluicebox, 4 months ago

Oh good, I'm glad it's working. The "g" at the start of the hash isn't a part of the hash, it is a prefix that I assume stands for git. "git checkout 62adf445b1" should work. I get confused by that every time.

Can you test the earlier version when you get a chance and let us know how it goes? If it works you can just close this ticket as "invalid". (Not that your plight isn't valid!)

comment:5 by tomasz89, 4 months ago

Works on 62adf445b1 too.

I recently fiddled with my Pulseaudio config because I could only get IEC958 stereo on my 5.1 setup until I changed config. I relate this because I am still suspecting a sound issue as you suggested. However, I can't seem to get back in to the bad state.

If anyone comes across this, check your sound setup because it is a requirement for the sound to play for the script to run through...

Closing as invalid.

comment:6 by tomasz89, 4 months ago

Owner: set to tomasz89
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.