Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#11456 closed defect (duplicate)

Crash on adding Simon The Sorcerer's Puzzle Pack - Demon In My Pocket

Reported by: ivanbraidi Owned by: criezy
Priority: normal Component: --Unset--
Keywords: Cc:
Game: Simon the Sorcerer Puzzle Pack

Description

First of all, all was working fine until version 2.1.

Now, when I try to add this particular game "Demon In My Pocket" (of 4 included in Simon The Sorcerer's Puzzle Pack) ScummVM correctly identifies the game, proposes the "Pick the game" pop-up, but when I click on "Choose", the program crashes after few seconds of "thinking".

It's important to highlight that the other 3 games all work fine, and the folder and data files selected are always the same.

I've already spoken with one of your devs and we tried to run ScummVM with debug level 11: no message is reported after clicking the "Choose" button.

  • ScummVM version: 2.1.x (daily build has the problem too, 2.0 and previous were OK)
  • Game language: English (original)
  • Game version: CD/Windows/English
  • OS: Now I have Windows 10 Pro Version 1909 (OS Build 18363.720), but previously I had Win 7 Pro and the problem was the same. It started from ScummVM version 2.1.

Attachments (2)

image-20200501-014824.png (96.6 KB ) - added by ivanbraidi 5 months ago.
image-20200501-014833.png (71.1 KB ) - added by ivanbraidi 5 months ago.

Download all attachments as: .zip

Change History (8)

by ivanbraidi, 5 months ago

Attachment: image-20200501-014824.png added

by ivanbraidi, 5 months ago

Attachment: image-20200501-014833.png added

comment:1 by criezy, 5 months ago

Could it be the same issue as bug #11433? The bug #11433 was reported for the Feeble Files but would have impacted all the games that do not have music. And checking our detection entries this is the case for Demon In My Pocket but not for the other 3 games. So to me it looks likely that this is the same bug.

However if that was the case, it would work with a daily build. Are you sure it crashes with a daily build (you need to test with a latest development build and not a latest stable build)?

comment:2 by ivanbraidi, 5 months ago

Yep, tested thoroughly today with the daily build: the problem remains.

I was aware of the other ticket but I still filed mine for this very reason.

Hope this could be useful to find a definitive solution.

comment:3 by ivanbraidi, 5 months ago

Oh wait! This is very weird: I just downloaded again the daily build and now it works... wtf??

comment:4 by ivanbraidi, 5 months ago

Well... seems like the problem's solved. Thank you and sorry for the fuss!

comment:5 by criezy, 5 months ago

Owner: set to criezy
Resolution: duplicate
Status: newclosed

Great, that's good news then!
I will mark as duplicate of bug #11433 and close.

comment:6 by ivanbraidi, 5 months ago

Perfect, thanks! ;)

Note: See TracTickets for help on using tickets.