#11444 closed defect (fixed)

XEEN: Crash if enemy hit with Energy Blast

Reported by: RX4NT9UP Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Version: Keywords:
Cc: Game: Might and Magic: World of Xeen

Description

If you cast the spell "Energy Blast" at an enemy (either ranged or in combat) the result will be a crash with the output:

TODO: Sprite drawer mode 2!

To reproduce:
Load save game, press c to open magic dialog, press f5 to choose sorcerer, press c again to cast.

ScummVM version:
ScummVM 2.1.1 (Mar 11 2020 10:32:58)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 JPEG PNG cloud (servers, local)

Game Language:
ENGLISH

Game Version:
DOS CD

OS:
Linux OpenSuse Leap 15.1

Attachments (1)

worldofxeen-cd.003 (222.7 KB ) - added by RX4NT9UP 18 months ago.

Download all attachments as: .zip

Change History (4)

by RX4NT9UP, 18 months ago

Attachment: worldofxeen-cd.003 added

comment:1 by RX4NT9UP, 18 months ago

Component: --Unset--Engine: Xeen
Game: Might and Magic: World of Xeen

comment:2 by RX4NT9UP, 18 months ago

Summary: XEEN: Crash if hit monster with Energy BlastXEEN: Crash if enemy hit with Energy Blast

comment:3 by dreammaster, 18 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Thanks for discovering this. The particular sprite drawer was one of the most complicated to understand, which is why I didn't originally implement it, since it didn't seem like it was used. Now that I know it was, I've spent the time to figure it out and commit an implementation. The fix will be available in the next nightly build.

Note: See TracTickets for help on using tickets.