Opened 2 years ago

Closed 5 months ago

#11431 closed defect (invalid)

SCI: QfG3 - "Tell about Pool" shouldn't be an option for Salim after the dispel potion

Reported by: lwcorp Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Quest for Glory 3

Description (last modified by lwcorp)

When Salim makes you the dispel option you can tell him about the Pool of Peace, just like you can tell him about all the ingredients for the dispel potion.

But after the potion is ready, this is the only remaining option and you can tell him about it for the rest of the game, which makes no sense. It shouldn't be an option at this point.

I've tried it in the latest Windows 64 build, v2.2.0git4593-gf531eba971 (Apr 20 2020 05:59:17)

Attachments (2)

image-20200417-143616.png (30.1 KB ) - added by lwcorp 2 years ago.
It shouldn't be an option at this point
qfg3.001 (59.9 KB ) - added by lwcorp 2 years ago.
Save game when it's still an option

Download all attachments as: .zip

Change History (7)

by lwcorp, 2 years ago

Attachment: image-20200417-143616.png added

It shouldn't be an option at this point

by lwcorp, 2 years ago

Attachment: qfg3.001 added

Save game when it's still an option

comment:1 by lwcorp, 2 years ago

Description: modified (diff)

comment:2 by raziel-, 2 years ago

Summary: QFG3: Tell about Pool shouldn't be an option for Salim after the dispel potionSCI: QfG3 - "Tell about Pool" shouldn't be an option for Salim after the dispel potion

comment:3 by lwcorp, 2 years ago

Description: modified (diff)

comment:4 by lwcorp, 2 years ago

Description: modified (diff)

comment:5 by sluicebox, 5 months ago

Owner: set to sluicebox
Resolution: invalid
Status: newclosed

I took a look at the script; the pool of peace water works just like the other ingredients. If you have it in inventory then you can tell Salim about it, if you don't then you can't. That's why the teller options go away as you give him the items. Whether or not he's already made the potion isn't a direct factor.

In the attached save game there is pool of peace water in inventory, and so you can tell Salim about it. Drop the water and then you can't.

Closing as this is original behavior that's working as intended.

Note: See TracTickets for help on using tickets.