Opened 8 months ago

Closed 3 months ago

#11429 closed defect (fixed)

PRINCE: "Look at" bug

Reported by: DirkPitt1 Owned by: sev-
Priority: normal Component: Engine: Prince
Keywords: Cc:
Game:

Description

I encountered a bug in The Prince and the Coward. When player uses command Obejrzyj/Look at on any object, player character comments and speech animation gets looped and game needs to be closed by Alt+F4 because it stops responding.

This bug occurs on latest daily build ScummVM 2.2.0git4499-g17e5b91410 from April 16 (32 and 64-bit version) but it doesn't occur on stable build 2.1.2.

Steps to reproduce:
1 Start new The Prince and the Coward game on latest ScummVM daily build for Windows
2 Choose any object/person and use "Obejrzyj/Look at" command on it
3 Character's speech animation gets looped.

Tested on Windows 10 1909 x64

Attachments (5)

scummvm 1.log (3.6 KB ) - added by DirkPitt1 8 months ago.
prince-pl.001 (28.8 KB ) - added by DirkPitt1 7 months ago.
scummvm.log (7.3 KB ) - added by DirkPitt1 7 months ago.
ScummVM 2.1.2.log (416.7 KB ) - added by mcfarrel 6 months ago.
ScummVM 2.2.0git5617-gc6bb053a09.log (286.6 KB ) - added by mcfarrel 6 months ago.

Download all attachments as: .zip

Change History (11)

by DirkPitt1, 8 months ago

Attachment: scummvm 1.log added

by DirkPitt1, 7 months ago

Attachment: prince-pl.001 added

by DirkPitt1, 7 months ago

Attachment: scummvm.log added

comment:1 by DirkPitt1, 7 months ago

Priority: highblocker

OK it seems that using Obejrzyj/Look at command is necessary to complete the game. In Castle Fjord player needs to look at some papers (save in the attachment) which they can't do because of this bug. One other information about the bug. When character's comment is short (one line) subtitles are shown but when comment is longer and subtitles are divided into several parts only the first part is displayed. Also there's one situation when Obejrzyj/Look at command doesn't break the game. When player looks at items in the inventory, this bug doesn't occur.

This issue was confirmed by one of my friends. I attach his debug log. His OS: Windows 10 x64 1909 (compilation: 18363.720). ScummVM: 2.2.0git4617-g8ab13e59e1 from April 23. He also confirmed that ScummVM 2.1.1a, 2.1.2 and 2.1.3 doesn't occur.

comment:2 by George22x, 7 months ago

I can confirm this bug.

comment:3 by digitall, 6 months ago

Priority: blockernormal

comment:4 by digitall, 6 months ago

Summary: The Prince and the Coward - "Look at" bugPRINCE: "Look at" bug

comment:5 by mcfarrel, 6 months ago

Still did encountered on both daily builds 20-05-19 mingw-w32-master-91013bac and mingw-w64-master-91013bac using Win7SP1 6.1.7601

Up to daily builds 20-01-31 mingw-w32-master-7079f010 and mingw-w64-master-7079f010 this bug has not been encountered.

by mcfarrel, 6 months ago

Attachment: ScummVM 2.1.2.log added

by mcfarrel, 6 months ago

comment:6 by sev-, 3 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

Finally fixed.

Note: See TracTickets for help on using tickets.