Opened 5 months ago

Closed 5 months ago

#11421 closed defect (fixed)

QFG3: autosave not supported, launches ScummVM save dialog

Reported by: lwcorp Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description (last modified by lwcorp)

Whenever there are places that are supposed to trigger an autosave, it just pops up the save/choose slot screen instead of actually saving.
I attached 2 different examples of this.

When trying to restore to it, it's also never clickable and just shows a black preview.

I've tried it in the latest Windows 64 build, v2.2.0git4593-gf531eba971 (Apr 20 2020 05:59:17)

Attachments (3)

black autosave.png (6.8 KB ) - added by lwcorp 5 months ago.
qfg3.001 (34.8 KB ) - added by lwcorp 5 months ago.
Save game just before leaving the city (walk down) thus triggering an auto save
qfg3.002 (32.8 KB ) - added by lwcorp 5 months ago.
Save game just before going to the money exchanger (walk left) thus triggering an auto save

Download all attachments as: .zip

Change History (9)

by lwcorp, 5 months ago

Attachment: black autosave.png added

comment:1 by lwcorp, 5 months ago

Description: modified (diff)

comment:2 by lwcorp, 5 months ago

Description: modified (diff)

comment:3 by lwcorp, 5 months ago

Description: modified (diff)

by lwcorp, 5 months ago

Attachment: qfg3.001 added

Save game just before leaving the city (walk down) thus triggering an auto save

by lwcorp, 5 months ago

Attachment: qfg3.002 added

Save game just before going to the money exchanger (walk left) thus triggering an auto save

comment:4 by lwcorp, 5 months ago

Description: modified (diff)

comment:5 by sluicebox, 5 months ago

I took a quick look, our restore patch is preventing the game's autosave script from running, which looks fixable by patching the Game superclass instead of the object. Then we'd probably want to detect the auto-save requests and map them to ScummVM slot 0 like in QFG4. I don't know this game though so maybe it works differently. I'll take a swing at this soon.

To clarify, no autosaving is taking place, so what's appearing is the normal save dialog just as if Save had been clicked from the control panel. Slot 0 always appears on the save dialog in thumbnail mode and it's black because it's an empty slot. Switching to list-mode will show all the slots and all the empty ones look the same.

An easy way to reproduce this is to use the debugger to go to room 640.

comment:6 by sluicebox, 5 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed
Summary: QFG3: autosave doesn't load (shows black preview) and prompts a popupQFG3: autosave not supported, launches ScummVM save dialog

Thank you for the report, QFG3 auto-save is now supported. Auto-saves are now saved to slot 0 without launching the ScummVM save dialog. If you enable the original save/load screens then the save will appear in the list as "Automatic Save" just like in the original and in QFG4.

Fixed in b57c205e30f99a2a595a452c6952aa267304f539

Note: See TracTickets for help on using tickets.