Opened 8 months ago

Closed 2 months ago

#11413 closed defect (fixed)

BACKENDS: WIN64 - Enable all command line parameters also for daily builds

Reported by: lwcorp Owned by: lotharsm
Priority: normal Component: Port: Win64
Keywords: Cc:
Game:

Description (last modified by lwcorp)

The first instruction in https://bugs.scummvm.org is to use a daily build first.
The second instruction is to report ScummVM's version (scummvm -v).

But turns out "-v" and most other command line parameters simply don't work (luckily, --conf does work) in daily builds. If you try to run them, nothing happens as if you clicked nothing.
In the case of "-v", this leads to another related issue.

So please make sure all command line parameters work in all situations.

Change History (14)

comment:1 by lwcorp, 8 months ago

Description: modified (diff)

comment:2 by lwcorp, 8 months ago

Description: modified (diff)

comment:3 by lwcorp, 8 months ago

Component: --Unset--Port: Win64

comment:4 by criezy, 8 months ago

This is an issue that has been reported many times (see for example tickets #11317, #10809, #9804, or #6907). From what I understand the issue is only when printing the result (so any command line parameter that does not print something, such as --config, will work properly). And this seems related to the way the application is built. From #11317 I understand that the daily builds from buildbot are compiled as a GUI application and exhibit the issue, while those directly linked at https://www.scummvm.org/downloads/#daily might be compiled as a console application and work properly.

I would be tempted to close this ticket (as the other ones have been closed), but since this is something that comes back now and then, I am wondering if buildbot should be changed to build a console Windows application as well, or if there is a good reason to build a GUI one. Also I am not a Window user myself and I am not sure I actually understand what the issue really is and what the implications are.

comment:5 by raziel-, 3 months ago

Summary: Enable all command line parameters also for daily buildsBACKENDS: WIN64 - Enable all command line parameters also for daily builds

comment:6 by necros2k7, 3 months ago

+1

comment:7 by lwcorp, 3 months ago

Description: modified (diff)

comment:8 by lotharsm, 2 months ago

Owner: set to lotharsm
Resolution: pending
Status: newclosed

This should be fixed now, since I'm now telling the linker to use "mconsole" instead of "mwindows" when linking SDL2 to the binary. In fact, this makes ScummVM a console application allowing the output as requested.

Since we are currently in a release cycle, it might take a while until the very latest development builds will have this feature - but it will be fixed in the subsequent builds.

Leaving this bug report open until I get confirmation from the reporter.

Thanks!

comment:9 by lotharsm, 2 months ago

Status: closedpending

comment:10 by lotharsm, 2 months ago

Resolution: pending
Status: pendingnew

comment:11 by lotharsm, 2 months ago

Resolution: pending
Status: newpending

in reply to:  8 comment:12 by lwcorp, 2 months ago

Replying to lotharsm:

Since we are currently in a release cycle, it might take a while until the very latest development builds will have this feature - but it will be fixed in the subsequent builds.

Leaving this bug report open until I get confirmation from the reporter.

Any chance you'll report here when it happens so I'll know to check and hopefully confirm?

comment:13 by lotharsm, 2 months ago

I just checked the builds - looks that buildbot is already providing the fixed builds with full command line support.

comment:14 by lotharsm, 2 months ago

Resolution: pendingfixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.