Opened 8 weeks ago

Closed 5 weeks ago

#11409 closed defect (fixed)

MIDI issues in three scenes of KQ6 outputting to SoundCanvas

Reported by: SunCrushr Owned by: ZvikaZ
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

When outputting to a SoundCanvas, there are MIDI issues in three scenes in KQ6.

  1. On the beach, at the start, the water crashing on shore sounds seems to build up and then get cut off, instead of fading out like it should.
  2. If you go north of the beach two screens, the music by the castle gates is playing the wrong instruments. It's supposed to be brass instruments, and instead id one brass instrument with piano and guitar instruments for the other notes, and the notes get cut off.
  3. When going north and west of the start screen to the screen with the lamp vendor, most of the sounds in the music that are supposed to be sustained get cut off.

This happens in both the current release (2.1.2) as well as the nightly build dated April 7.

Change History (3)

comment:2 by ZvikaZ, 6 weeks ago

BTW, Chris Wadge, the author of FatBoy reported to me (by mail) a problem in GK1 intro, demonstrated at https://youtu.be/fBEXFxhBpxY:

Most (all?) presets use incorrect sustain, cutting off prematurely

This problem is also solved by the same PR - https://github.com/scummvm/scummvm/pull/2182

comment:3 by ZvikaZ, 5 weeks ago

Owner: set to ZvikaZ
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.