Opened 6 months ago

Closed 6 months ago

#11400 closed defect (invalid)

GK2 Consistent Crashes at CH4, Seeshaupt

Reported by: pixelmischief Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: SCI, GK2, Seeshaupt, run_vm Cc:
Game: Gabriel Knight 2

Description (last modified by pixelmischief)

Windows 10 x64, Version 10.0.18363, ScummVM 2.1.1a (Feb 3, 2020 21:46:14)
In Chapter 4, Grace travels to a location called Seeshaupt. Once she is there, any move she makes will cause SCUMMVM to crash. The error is:

run_vm(): program counter gone astray, addr: 4665, code buffer size: 2312!

You can reproduce the error by loading the attached save game file, gk2.007 (Ch4DontCrash2). If you want to see the state of the game before the inescapable crash condition, use attached gk2.006 (Ch4DontCrash).

Attachments (3)

gk2.006 (54.4 KB ) - added by pixelmischief 6 months ago.
gk2.007 (53.5 KB ) - added by pixelmischief 6 months ago.
image-20200330-164937.png (388.4 KB ) - added by pixelmischief 6 months ago.

Download all attachments as: .zip

Change History (13)

by pixelmischief, 6 months ago

Attachment: gk2.006 added

by pixelmischief, 6 months ago

Attachment: gk2.007 added

by pixelmischief, 6 months ago

Attachment: image-20200330-164937.png added

comment:1 by pixelmischief, 6 months ago

Description: modified (diff)

comment:2 by dafioram, 6 months ago

Where did gk2? I can't see/load either of your saves. Yours are about 7KB and all my previous gk2 saves are in the 40KBs. I can take grace to Seeshaupt just fine using my old saves.

comment:3 by pixelmischief, 6 months ago

Not sure what's up with the size problem on the downloads. When I look here on the site and when I re-download them myself, they have the right sizes and I can load them.

comment:4 by ZvikaZ, 6 months ago

When I tried these saves, they are 54/55KB - I can load them, but get immediate crash (on both saves) - different than yours:

ERROR: Unknown SegmentObj type 44!

Tried with the same ScummVM version as yours (ScummVM 2.1.1a (Feb 3, 2020 21:46:14) on Windows 10).

Maybe your GK2 is corrupted?

BTW,
I assume you did it, but just to make sure...
Have you tried loading these save files yourself, and verified that they indeed load?

Last edited 6 months ago by ZvikaZ (previous) (diff)

comment:5 by pixelmischief, 6 months ago

Hmmmm. I got my ScummVM target archive in some "all the things" download. Let me grab my original media and pull a clean copy of the dats. Stand by...

comment:6 by pixelmischief, 6 months ago

Please close the ticket. The problem was my using an un-patched distribution of the GK2 data files. I have now dumped from original media and patched to 1.11. Everything is working fine; including saved games.

Last edited 6 months ago by pixelmischief (previous) (diff)

comment:7 by sev-, 6 months ago

Maybe it would be nice to still either patch on the fly or detect such unpatched version and suggest patching?

comment:8 by ZvikaZ, 6 months ago

@pixelmischief , following @sev's suggestion - could you elaborate on that patching?
I bought my version from GOG not a long ago, and it's already patched probably.

Can you detail what's the procedure you did to patch (and where did you see the patching instructions), so I could try "unpatching"?

comment:9 by pixelmischief, 6 months ago

I found the Sierra help pages at:

http://www.sierrahelp.com/Patches-Updates/Patches-Updates-Games/GabrielKnightSeriesUpdates.html

I only installed the patch at:

http://www.sierrahelp.com/Files/Patches/GabrielKnight/GK2(GK2PAT).zip

This patch, appropriately enough, is described as "address[ing] chapter 4 memory problems[,] the error 99 gotten when changing CDs and the chapter 6 Lockup when taking the holy water."

comment:10 by sluicebox, 6 months ago

Owner: set to sluicebox
Resolution: invalid
Status: newclosed

Closing as requested. There's some confusion on this thread, which is understandable, since there's a few GK2 versions and patches.

As the reporter noted, there is no bug here, they had corrupt files they downloaded from a torrent or something.

This is unrelated to patching. This is unrelated to version 1.00, as that's not the version they had. They had 1.1, which you can tell by the version string in the save games. I loaded and played the saved games just fine using 1.1 media.

The reporter solved this by using real media. They also applied the 1.11 patch, but that was irrelevant, since the problem was using a rando zip with broken resource files instead of real media.

We've already backported the bugfixes in the GK2 patches to all earlier versions.

Note: See TracTickets for help on using tickets.