Opened 11 months ago

Last modified 3 months ago

#11396 new defect

SWORD2: (SPANISH DEMO) Save/Load/Options UI is visually broken, soft-freeze when opening the guardhouse's trap door

Reported by: IlDucci Owned by: sev-
Priority: high Component: Engine: Sword2
Version: Keywords: Broken Sword 2, demo, Spanish
Cc: Game: Broken Sword 2

Description

Greetings. I have uploaded a copy of Broken Sword's 1 and 2 demos in Spanish (found in Micromanía discs 24 and 33 respectively) and started testing both. I've started with BS2, since the program detected it as a demo.

I've managed to beat the demo from start to finish with only one softlock. Here's my specs:

ScummVM version 2.2.0git3932-g4a7f8c18c5 (Mar 14 2020 05:15:21)

Bug details, including step-by-step instructions to reproduce the bug

Language of game: Spanish (with voices)
Version of game: PC Demo (from Micromanía's disc 33)
OS: Win 10 64-bit build 1809

The screenshots attached are related to the UI and they should talk by themselves: The background and some buttons are off their correct places. I do not know if this error happened in the original EXE.

As for the bug, I was not able to reproduce the bug, but after the guard opens the trapdoor, the first time I tried to enter it, George didn't display the animation where he tries to climb the structure, the game just faded to black... and stayed there. After reloading a save, George did the animation and the demo proceeded as usual.

Attachments (3)

scummvm-sword2demo-00000.png (102.5 KB ) - added by IlDucci 11 months ago.
scummvm-sword2demo-00001.png (78.1 KB ) - added by IlDucci 11 months ago.
sword2demo-es.002 (286 bytes ) - added by IlDucci 3 months ago.

Download all attachments as: .zip

Change History (8)

by IlDucci, 11 months ago

by IlDucci, 11 months ago

comment:1 by sev-, 6 months ago

Priority: normalhigh

comment:2 by sev-, 6 months ago

For having the dialogs fixed I need the untouched demo. The files which you provided earlier are in weirdly placed directories and at least resource.inf file is missing, thus, the original executable cannot run.

Could you please re-upload the BS2-es demo but untouched (maybe it was inside some kind of archive?)

comment:3 by sev-, 6 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

Fixed.

comment:4 by sev-, 6 months ago

I also could not reproduce the trap door bug.

comment:5 by IlDucci, 3 months ago

Resolution: fixed
Status: closednew

I have successfully reproduced the trapdoor bug. If you enter the trapdoor by just left-clicking it, George will enter it with its proper animation. However, if you first right-click the trapdoor, let the description dialogue be played, and then left-click the trapdoor, the game will fade to black and softlock.

I am attaching a savegame using ScummVM version 2.3.0git11098-gd70bdfa033.

by IlDucci, 3 months ago

Attachment: sword2demo-es.002 added
Note: See TracTickets for help on using tickets.