Opened 9 days ago

Closed 7 days ago

#11388 closed defect (duplicate)

Humungous Macintosh Demos from ScummVM demo page crash on startup

Reported by: Thunderforge Owned by: Thunderforge
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description (last modified by Thunderforge)

  1. Go to the official ScummVM demo page
  2. Download any of the following games from Humongous Entertainment:
    • Freddi Fish 1: The Case of the Missing Kelp Seeds (Macintosh Demo)
    • Let's Explore the Airport with Buzzy (Macintosh Demo)
    • Putt-Putt Saves the Zoo (Macintosh Demo)
  3. Unzip the demo
  4. Launch ScummVM
  5. Add the game (in each case, it is correctly recognized by ScummVM)
  6. Start the game

The result is an immediate crash to the console with the following message

ScummVM 2.1.1 (Jan 19 2020 21:34:26)
Console is ready
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: (0:1:0x94): Could not extract cursor 102!


)

The errors are as follows:

  • Freddi Fish is 0:1:0x94
  • Let's Explore the Airport is 0:1:0x5A
  • Putt-Putt is 0:1:0x48

I tried the The Dig (Macintosh demo) since it also uses SCUMM, but the game started up successfully

This was all tested on macOS 10.14. I would expect that macOS would not run into any sort of extraction issue.

Change History (3)

comment:1 by Thunderforge, 9 days ago

Description: modified (diff)

comment:2 by angstsmurf, 8 days ago

Duplicate of #11375

comment:3 by Thunderforge, 7 days ago

Owner: set to Thunderforge
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.