Opened 5 months ago

Closed 5 months ago

#11338 closed defect (invalid)

3DS: Crashes connected to dynamic plugins

Reported by: BallM4788 Owned by: bgK
Priority: low Component: Ports
Keywords: port, 3DS, dynamic, plugin, SCUMM, secret, sammax, MOHAWK, riven, NEVERHOOD, neverhood Cc:
Game:

Description

Introduced in commit 34e835a

Last unaffected release: v2.1.0
First affected release: v2.1.1

Bug details: When a 3DS port is built with dynamic plugins enabled, attempting to quit or return to the launcher menu from within some (possibly all) SCUMM games (or in rare cases attempting to start a SCUMM game) will cause the system to crash. Crashing will not occur if dynamic plugins were disabled at compile time.

Games confirmed to be affected:
Sam & Max Hit the Road (CD DOS, English)
The Secret of Monkey Island (CD DOS, English)

Games speculated to be affected:
All SCUMM games

Games used to trigger or except bug:
The Neverhood (CD Windows, English)
Riven: The Sequel to Myst (GOG.COM, English)

Known cases and steps to replicate:
Case 1:
1) Start ScummVM.
2) Start a SCUMM game (Ex: "Sam & Max", "Secret of Monkey Island").
3) Once game has started, open the options menu (START button).
4) Select either "Return to Launcher" or "Quit"; both result in a system crash.
Note: Opening and closing "Riven" between steps 1 and 2 was successful, but did not prevent the crash in step 4.

Case 2:
1) Start ScummVM.
2) Start "The Neverhood".
3) Once game has started, open the options menu (START button).
4) Select "Return to Launcher".
5) Attempt to start a SCUMM game (ex: "Sam & Max", "Secret of Monkey Island"); system will crash.

Known exception case:
1) Start ScummVM.
2) Start "The Neverhood".
3) Once game has started, open the options menu (START button).
4) Select "Return to Launcher".
5) Start "Riven: The Sequel to Myst".
6) Repeat steps 3 and 4.
7) Start a SCUMM game (Ex: "Sam & Max", "Secret of Monkey Island").
8) Repeat step 3.
9) Select either "Return to Launcher" or "Quit"; both will complete successfully.
10) If "Return to Launcher" was selected, "Return to Launcher" will also work successfully from within any subsequently started game in the same ScummVM session.
Note: "Neverhood" must be opened BEFORE "Riven" for a crash to be avoided.

Attachments (1)

backtrace.txt (3.1 KB ) - added by BallM4788 5 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by bgK, 5 months ago

Hi,

I cannot reproduce this issue with the 2.1.1 release build. Could you please post a backtrace of the crash?

comment:2 by BallM4788, 5 months ago

How do I do a backtrace on 3DS?

comment:3 by bgK, 5 months ago

I've posted some instructions there: https://bugs.scummvm.org/ticket/11292#comment:4

comment:4 by BallM4788, 5 months ago

Thanks. Might be a day or two before I can get back to you on this, depending on whether or not it turns out to be a problem with the SD card (it probably isn't, but I've backed up the data and am doing a deep format on it anyway just to be sure).

Last edited 5 months ago by BallM4788 (previous) (diff)

by BallM4788, 5 months ago

Attachment: backtrace.txt added

comment:5 by BallM4788, 5 months ago

Okay I'm back. SD card's fine, so I recompiled ScummVM and I'm no longer getting the crashes either. I think the problem was on my end, as I hadn't done a distclean in a while. I did do a backtrace from the un-distcleaned compile though; I've attached it just in case.

comment:6 by BallM4788, 5 months ago

Priority: highlow

comment:7 by BallM4788, 5 months ago

Changed priority to low.

comment:8 by bgK, 5 months ago

Owner: set to bgK
Resolution: invalid
Status: newclosed

Ok, good it was probably a build problem. I'm closing this. Please re-open if you can reproduce the issue with a clean build.

Note: See TracTickets for help on using tickets.