Opened 9 months ago

Closed 9 months ago

#11335 closed defect (fixed)

GOB3: Music not playing during chess room

Reported by: lawadr Owned by: lawadr
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

The chess room is supposed to have two music tracks. In MUS_GOB3.LIC they are named ECHIQUI1 and ECHIQUI2 and occur from around 24:24 to 25:36 in the soundtrack.

The game scripts seem to request the tracks ECHEQUI1 and ECHEQUI2 instead (note the typos), and ScummVM spits out the following:
"WARNING: CDROM: Track "ECHEQUI1" not found!"
"WARNING: CDROM: Track "ECHEQUI2" not found!"

This looks like a bug in the original game and prevents the player from ever hearing the two music tracks during the chess level.

Reproduced on:
ScummVM 2.0.0 (Dec 9 2017 07:14:40)
ScummVM 2.1.0 (Oct 5 2019 01:08:33)

Game version:
Goblins Quest 3 CD (v1.02/DOS/English)

Attachments (1)

gob3cd.s00 (17.4 KB ) - added by lawadr 9 months ago.
Chess room save

Download all attachments as: .zip

Change History (2)

by lawadr, 9 months ago

Attachment: gob3cd.s00 added

Chess room save

comment:1 by bluegr, 9 months ago

Owner: set to lawadr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.