Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#11328 closed defect (duplicate)

Queen: Bellboy talk bug hotel lobby

Reported by: Urgeistenergie Owned by: criezy
Priority: normal Component: Engine: Queen
Keywords: Queen Bug Bellboy Cc: Urgeistenergie
Game: Flight of the Amazon Queen

Description (last modified by Urgeistenergie)

In the beginning of the game at hotel lobby scene it is not possible to talk to the bellboy properly. All selected dialogs won't be executeted. Instead the protagonist quits the the talk with "I have to go". The bug makes the game unplayable because it is nessecary to talk about the key on the desk.

The bug was introduced with ScummVM v2.1.0.
With ScummVM v2.0.0 it works fine and the bug is not present.

The bug is present in at least 2 languages:
Flight ot the Amazon Queen (Talkie/DOS/German)
Flight ot the Amazon Queen (Talkie/DOS/English)

Bug is OS independet. Testet with:

  • Linux Manjaro 18.1 x86_64 (Arch)
  • Windows 10 x64 Pro build 1909

Attachments (1)

queen.s00 (12.3 KB ) - added by Urgeistenergie 8 months ago.
Savegame

Download all attachments as: .zip

Change History (4)

by Urgeistenergie, 8 months ago

Attachment: queen.s00 added

Savegame

comment:1 by Urgeistenergie, 8 months ago

Description: modified (diff)

comment:2 by criezy, 8 months ago

Owner: set to criezy
Resolution: duplicate
Status: newclosed

Duplicate of bug #11272.

The bug has been fixed already with https://github.com/scummvm/scummvm/pull/1972 and the fix will be included in ScummVM 2.2.0.

comment:3 by Urgeistenergie, 8 months ago

Thanks for fixing!

I didn't see that the bug had already been reported.

Note: See TracTickets for help on using tickets.