#11320 closed defect (invalid)

GK2 subtitle compatibility not working as it should.

Reported by: abogard Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: Gabriel Knight 2

Description

Hello. I couldn't get this to work properly. The current english subtitles patch was first created for the spanish language, some guy just substituted the text to get it working in english. In game the subtitles show and for movies they work great but when you're in the exploring parts you can see the subtitle but the voice file don't play. Also the subtitles are showing in the bottom screen and the middle of the screen (they effectively show twice at the same time), the patch as it works in vanilla (namely DOSBOX) is showing the subtitles in the bottom part of the screen only, outside the gameplay area. I tried with the file versions of my original discs and the GOG version. This is what I get in the log:

[2020-01-12 10:35:24] --- Log opened.
[2020-01-12 10:35:24] WARNING: No voice is available for language: es!
[2020-01-12 10:35:57] WARNING: Resource type mismatch loading audio36.210(23, 62, 0, 1)!
[2020-01-12 10:35:57] WARNING: resMan: Failed to read audio36.210(23, 62, 0, 1)!
[2020-01-12 10:35:57] WARNING: [Audio32::play]: audio36.210(23, 62, 0, 1) could not be found!

I'm attaching 3 screenshots. The first shows Scummvm, the second is the Scummvm status window and the third is DOSBOX. You can see in DOSBOX the subtitles are shown in the bottom part of the screen, besides that the audio with the actual speech is heard as well.

Attachments (6)

test gk2.jpg (307.4 KB ) - added by abogard 15 months ago.
test gk2-1.JPG (97.1 KB ) - added by abogard 15 months ago.
test gk2-2.jpg (132.7 KB ) - added by abogard 15 months ago.
test gk2-3.JPG (42.1 KB ) - added by abogard 15 months ago.
test gk2-4.JPG (52.7 KB ) - added by abogard 15 months ago.
test gk2-5.JPG (117.8 KB ) - added by abogard 15 months ago.

Download all attachments as: .zip

Change History (16)

by abogard, 15 months ago

Attachment: test gk2.jpg added

by abogard, 15 months ago

Attachment: test gk2-1.JPG added

by abogard, 15 months ago

Attachment: test gk2-2.jpg added

comment:1 by sluicebox, 15 months ago

Hello, thank you for reporting this. I'm glad you're trying the subtitle patch! I'm really excited about getting it to work.

The problems you're seeing are unrelated to subtitles. You have set the ScummVM language setting of the game to Spanish, which it is not, and so the game scripts are looking for Spanish audio. Since none exists, it is displaying text in the center, which is what the game always does as a fallback when it can't find any audio. (That's good, because the English version is missing audio for a couple messages)

You just need to set the ScummVM language setting for the game back to English using the Edit Game button. I'm confused as to how that setting managed to end up Spanish in the first place, you would have had to set that yourself, but that setting should be disabled since you can only break the game by changing it. At least, it's disabled for me.

comment:2 by abogard, 15 months ago

Hello, thanks for the response. I did think about what you said but it just doesn't seem right to me because of one reason: I don't have the game configured in spanish. I'm sending another 3 screenshots, you can see the game configuration in the Scummvm gui (as a matter of fact the language option is greyed out and it can't be changed there) and the ini file, both are clearly in english but I'm also sending you a screenshot of the Sierra help pages where it says that these files were originally made for spanish and the author just modified the text to make it english compatible. My theory is that Scummvm is detecting something inside the modified files (that says they're for a spanish version of the game) and is acting upon that. That being said I'd like to know where did you get a working english subtitles patch, maybe the answer is to use the correct subtitles patch but I just don't know of the existence of any other version. Also it may be possible that editing the ini file with the correct option works but in this you're the expert. I really appreciate the work you're doing because this is one of my favorite games.

by abogard, 15 months ago

Attachment: test gk2-3.JPG added

by abogard, 15 months ago

Attachment: test gk2-4.JPG added

by abogard, 15 months ago

Attachment: test gk2-5.JPG added

comment:3 by sluicebox, 15 months ago

You're right! You have it configured correctly. That's good news because I didn't know how to explain that and figured you would have mentioned editing the ini. You do not need to edit the ini.

The "es" in the logs does mean that the game has somehow ended up thinking it is in Spanish. Plus that explains the behavior.

I got the English and Spanish patches from sierrahelp.com and they both worked for me. I installed them by opening the exe with 7zip, going to the directory with all the sierra patch files, and manually putting them in the directory. (If there's a PATCHES directory, put them there.)

I'll look into this.

comment:4 by sluicebox, 15 months ago

Can you try something? Please bring up the debugger with CTRL + SHIFT + D, enter this command, and report what it says:

send GK2 printLang

ESC or "exit" will exit the debugger

comment:5 by abogard, 15 months ago

The debugger sent me this:

Message completed. Value returned: 0000:0001

And just in case when I first tried the patch I put everything in the patches folder and it was the same behavior, the I saw the past ticket and you wrote there to just put everything in the game directory so that is what I did last.

comment:6 by sluicebox, 15 months ago

I just setup a fresh copy of the GOG version with the english subtitle patches and it works.

Try setting up a fresh copy of the GOG release and running it in ScummVM without the patch. If the audio works, and then you add the subtitle patch, and then audio stops, we know it's related to the patch, though I can't imagine how that could be, in which case please post md5sums of everything in your game directory and patches directory.

comment:7 by abogard, 15 months ago

Lo and behold! Now it's working fine. I did exactly how you told me and it is working as intended. You can't possibly know how happy I am. Now I think it is important to take this example of how to make it work because it seems not to be working with a manual installation (getting the files straight from the original discs) because that's what I have, the other test I did was not from GOG (my mistake) but the installation made by the Sierra installers found in sierrahelp.com. Now I don't know if it works with Steam but it probably does. If it helps the GOG installer does create a PATCHES subdir with various files in it, I replaced everything that had the same name, it is also of note that you need 7zip to unpack the installer and only copy the contents of the SUBPATCH folder. The message that Scummvm puts in the log that says "No voice is available for language: es!" is appearing in all of my games so it wasn't just for that particular game, I guess it's because my OS is in spanish, I say this because it means that the problem probably wasn't that the engine was thinking about an spanish version of the game but something else entirely. In conclusion at least for now we better stick to the GOG version to make it work perfectly. Thanks a lot for your help.

comment:8 by m-kiewitz, 15 months ago

At some point we will include subtitle support inside ScummVM just like we did with quite a few other titles, so these patches will not be required or needed anymore. The patches are quite a mess.

comment:9 by ZvikaZ, 15 months ago

Until the point that we'll include subtitle support inside ScummVM, maybe someone will summarize the steps required to apply that patch? (where exactly to download it from, where exactly to put it).
Maybe even write it in the README, or as a notice when the game begins. (after all, most users won't reach this issue report...)

comment:10 by sluicebox, 15 months ago

Owner: set to sluicebox
Resolution: invalid
Status: newclosed

Glad you got this to work! For the record:

  • The problem was that your resources files were corrupted, you were missing audio.
  • The subtitle patches absolutely work with original game disc files. That's how I use them.
  • The "No voice is available for language: es!" message had nothing to with any of this.


I don't know how we would natively add subtitles since it relies on script, font, and sync resources for each video that's not in any version except Portuguese.

We can write up the install steps up on the wiki for how to use the patches, but they work just fine. The friction is that they're distributed as an old installer. Maybe we can ask sierrahelp.com to also package the patch files as a zip.

I think another thing confusing GK2 users is that some of them are trying to use that installer that merges game disc files.

Note: See TracTickets for help on using tickets.