Opened 10 months ago

Closed 3 months ago

Last modified 3 months ago

#11316 closed defect (fixed)

PINK: RTL - Hebrew is reversed (Left to Right instead of Right to Left)

Reported by: ZvikaZ Owned by: sev-
Priority: normal Component: Engine: Pink
Keywords: hebrew RTL Cc:
Game: Pink Panther: Passport to Peril

Description

Hi.
Just tried running "The Pink Panther: Passport to Peril (Windows/Hebrew)", and it's loading fine, but all the Hebrew text is reversed - it's shown from left to right (LTR), instead of right to left (RTL).

E.g.,
In the menu bar, instead of "משחק" ("game"), it's written "קחשמ" ("emag")

I'm using the nightly build, 2.2.0git2067-ge0810084ab, built on Jan 19 2020 04:20:32

Attachments (1)

Screenshot 2020-08-27 at 16.20.57.png (113.6 KB ) - added by sev- 3 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by raziel-, 4 months ago

Summary: Hebrew is reversed (Left to Right instead of Right to Left)GUI: RTL - Hebrew is reversed (Left to Right instead of Right to Left)

Duplicate to #11204 and #11205

comment:2 by raziel-, 3 months ago

Since both duplicates have been closed, I guess this can be closed as well?

comment:3 by sev-, 3 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

Absolutely

comment:4 by ZvikaZ, 3 months ago

Resolution: fixed
Status: closednew

Well, I should have replied earlier...
This bug is not a duplicate of https://bugs.scummvm.org/ticket/11204 and https://bugs.scummvm.org/ticket/11205 , as they're regarding the ScummVM's GUI, while this bug is specific for Panther's GUI.

Our ScummVM GUI BiDi code doesn't modify the in-engines behaviour, and each engine has to specifically handle it.

Maybe it was fixed in Panther by someone, but it's not related to https://bugs.scummvm.org/ticket/11205 fix.

Maybe I'd better verify that it's still relevant, but I don't have Panther installed anymore, and since actually https://bugs.scummvm.org/ticket/11205 was fixed by me, and no one reported fixing this bug, I assume leaving it open makes sense.

comment:5 by ZvikaZ, 3 months ago

Summary: GUI: RTL - Hebrew is reversed (Left to Right instead of Right to Left)PINK: RTL - Hebrew is reversed (Left to Right instead of Right to Left)

comment:6 by sev-, 3 months ago

In fact, this was truly fixed 4 months ago as part of a bigger PR. See for instance 432dd88bdbad77abcd943228b4a2ad799593f88a

Please also check the attached screenshot.

comment:7 by sev-, 3 months ago

Resolution: fixed
Status: newclosed

comment:8 by ZvikaZ, 3 months ago

Well, I'm glad to see that I was mistaken :-)
The screenshot is indeed correct, and the bug is fixed.

Note: See TracTickets for help on using tickets.