Opened 8 months ago

Closed 8 months ago

#11312 closed defect (fixed)

KYRA: Kyrandia 3. Some graphics issues

Reported by: ctoroman Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 3

Description

Savegames in bugs-kyr3.zip

Bug1. You are at the far end of the room in the cafe. Relive the squirrel with a fishing rod. When everyone starts to run away, Malcolm will be at the entrance to the cafe.

Bug2. The statue of the mouse merges with the statue of the cat in the background. When you give the mouse cheese, the statues of cats will curl up into balls, and the statue of the mouse will come to the fore.

Attachments (3)

bugs-kyr3.zip (40.8 KB ) - added by ctoroman 8 months ago.
screen1.jpg (280.7 KB ) - added by ctoroman 8 months ago.
screen2.jpg (285.7 KB ) - added by ctoroman 8 months ago.

Download all attachments as: .zip

Change History (16)

by ctoroman, 8 months ago

Attachment: bugs-kyr3.zip added

comment:1 by athrxx, 8 months ago

I am not sure I understand bug1. Are you sure that this is a bug? I've looked up that situation on YouTube and it seems to be the same?

Bug2 does indeed look weird. I have also checked that with YouTube. The mouse should be in the front and the other statues should wrap up cleanly without overlapping. I'll try to fix that...

comment:2 by ctoroman, 8 months ago

I'm sorry, I put it a little incorrectly. When everyone runs out of the cafe, Malcolm is seen outside the building. And he must be inside.

comment:3 by athrxx, 8 months ago

Okay, I have committed a fix for bug 2. The cats should now be behind the mouse.

I have also watched the bug 1 scene several times, but I still fail to see any issue there. Could you please attach a screenshot with Malcolm being in the wrong place?

comment:4 by ctoroman, 8 months ago

Of course I can ). In this screenshot, Malcolm is standing outside the building while the last visitor escaped from the building. Although in fact it should be inside. Run Bug1 from the saved game, revive the squirrel and pay attention to where Malcolm stands when they run out of the cafe.

by ctoroman, 8 months ago

Attachment: screen1.jpg added

by ctoroman, 8 months ago

Attachment: screen2.jpg added

comment:5 by ctoroman, 8 months ago

P.S. Maybe I speak incomprehensibly, please forgive my English, because I'm Russian). I communicate through a translator :)

comment:6 by ctoroman, 8 months ago

P.P.S. Games about Kyrandia and Myst I love since childhood (199x). I am very glad that a program like ScummVM and ResidualVM has appeared. And that there is such a good person who is able to modify the game engine to the state of perfection :) Thank you for supporting these games (Kyra). I think I saw all the bugs that are clearly striking. Good luck in your business :)

comment:7 by athrxx, 8 months ago

Thanks for the screenshots (and also for the kind words :)).

Now I can see what you're talking about. The weird thing is that this bug does not occur when I run my normal ScummVM build. But when I download the automated build from our website the bug will be there. I'll try to come up with a fix...

comment:8 by athrxx, 8 months ago

I have just committed a fix that should address bug 1.

Please test this. My bug fix is a bit experimental, since that bug will not occur in all ScummVM builds.

comment:9 by ctoroman, 8 months ago

I tested fix. Nothing has changed :( Everything is as in the screenshots

UPD: I downloaded the build from here:

https://www.scummvm.org/frs/daily/scummvm-snapshot-win32.exe

No bug :)

But when I build my program from .git (branch master), a bug is present (

When i downloaded the build from

https://buildbot.scummvm.org/snapshots/master/mingw-w32-master-latest.zip

A bug is present.

Last edited 8 months ago by ctoroman (previous) (diff)

comment:11 by athrxx, 8 months ago

Thanks for all that testing :)

No, it is all from the same source. The problem is that the bug depends on the used build chain and how it is configured. That's why it is tricky to hunt it down. I never got that bug with my Win64 MSVC builds.

However, I have been able to reproduce the bug locally with a linux build and it seems that I was able to fix it. At least it is now gone from my linux build.

I have committed a new fix which gets rid of the bug for me. Please test again.

As you seem to be able to make your own builds I recommend using that (since that assures you're really using the newest version).

comment:12 by ctoroman, 8 months ago

Yes, I use my own builds. It's more comfortable for me :)

YES!!! You did it! Thank you so much for your work!
I think the Kyrandias are fully fixed. If I find anything else :)

Last edited 8 months ago by ctoroman (previous) (diff)

comment:13 by athrxx, 8 months ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed

Yeah, I've just tested the mingw-w64-master-latest.zip and that seems to be fine, too.

Thanks for all your help :)

Now, I'll go back to fixing that Kyra 1 AdLib music bug... (that one is also tricky).

Note: See TracTickets for help on using tickets.