Opened 11 days ago

Closed 7 days ago

#11311 closed defect (duplicate)

Not getting some sound effects with General MIDI (but it's working in DosBOX)

Reported by: ZvikaZ Owned by: ZvikaZ
Priority: normal Component: Engine: SCI
Keywords: general-midi multi-midi Cc:
Game: Gabriel Knight 1

Description (last modified by ZvikaZ)

Hi.
Tried playing Gabriel Knight (CD/Dos and Windows/English) with General Midi (tried FluidSynth [with FatBoy 0.786, and some other SF - 'Roland SC-55 v3.7.sf2'] and with MS Windows MIDI) - the music is great, but there are no sound effects when I get points.
Tried changing to MT-32 emulator - the music is good, but less than GM - however, now I get these sound effects.

The "Mixed Adlib/MIDI mode" is clicked in ScummVM general options menu. (It doesn't show in the game's specific options menu - is that the source of my problems?)

Tried with DosBOX, and in Sierra's original install utility there are separate settings for "Music" (I chose General MIDI) and "Sound" (chose Sound Blaster) - and it seems to work fine (there are some other issues with DosBOX - I really prefer using ScummVM - but the music/sound issue is better with DosBOX).

Bottom line:
It seems that there is a problem with '--multi-midi' option here.

Versions:

Microsoft Windows [Version 10.0.17763.914]

ScummVM 2.1.0 (Oct 5 2019 01:07:22)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 JPEG PNG cloud (servers, local)

Gabriel Knight - GOG release - bought yesterday.

Change History (2)

comment:1 by ZvikaZ, 11 days ago

Description: modified (diff)

comment:2 by ZvikaZ, 7 days ago

Owner: set to ZvikaZ
Resolution: duplicate
Status: newclosed

This was already reported before.
https://bugs.scummvm.org/ticket/9735
Closing.

Note: See TracTickets for help on using tickets.