#11306 closed defect (fixed)

BLADERUNNER: Sprint Speed

Reported by: HippoPenguin Owned by: antoniou79
Priority: low Component: Engine: Bladerunner
Version: Keywords:
Cc: antoniou79 Game: Blade Runner

Description

Maybe there is a reason but I find Ray's sprinting speed doesn't go as fast as it should do. In a Windows/WINE installation of the game if you kept clicking on a location such as his car, he would get run to it faster and faster if you kept clicking.

Change History (5)

comment:1 by antoniou79, 12 months ago

Cc: antoniou79 added
Component: --Unset--Engine: Bladerunner
Summary: Blade Runner - Sprint SpeedBLADERUNNER: Sprint Speed

comment:2 by antoniou79, 12 months ago

This should be fixed with:
https://github.com/scummvm/scummvm/commit/d4c659610daf371e5313a3094d6a109cf27c7c1b

However, as far as I could tell, there was a bug in the original engine which ignored the stamina drain system.
With our bugfix:

  • in the vanilla mode, you'll need to keep clicking for McCoy to reach max running speed and still keep clicking for him to maintain it.
  • in the restored content mode, we implemented an alternate approach to the drain system, which essentially allows McCoy to run fast without the player constantly clicking the mouse (McCoy's stamina will drain, but slower, and depending on how fast he is running)

comment:3 by antoniou79, 12 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newpending

comment:4 by antoniou79, 11 months ago

I've pushed a new commit which adds a new engine option to "Disable McCoy's quick stamina drain".

This is disabled by default.

It can be enabled, to get the original behavior (which was actually caused by a bug), whereby McCoy can run fast for as long as he wants (until he is stopped or starts walking) without slowing down as soon as the player stops clicking the mouse.

Relevant Commit:
https://github.com/scummvm/scummvm/commit/11adaa4f3db382451e3a87bc584d722487b41465

To see the new engine option, under the Engine tab (Edit Game... mode), you should use a ScummVM build (after this commit) and do *one* of the following:

  • Start the (already added) Blade Runner game once via ScummVM, then exit, and check the ScummVM launcher in "Edit Game" screen. The Engine tab should now have the new checkbox option.
  • Re-Add the game in ScummVM
  • Manually add the "disable_stamina_drain=false" key-value pair in the ScummVM config file (eg. scummvm.ini) under the appropriate section for the Blade Runner game and also make sure that the guioptions key in the same section contains the gameOption5 value (space separated from the rest)

If there's no more feedback for this issue by the ticket creator, I intend to close the ticket (as fixed) during the weekend.

Last edited 11 months ago by antoniou79 (previous) (diff)

comment:5 by antoniou79, 11 months ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.