Opened 13 months ago

Last modified 6 weeks ago

#11305 new defect

BACKENDS: MacOSX - Dark Mode is not supported

Reported by: Thunderforge Owned by: criezy
Priority: normal Component: Port: Mac OS X
Version: Keywords: dark-mode
Cc: Thunderforge Game:

Description (last modified by Thunderforge)

Dark Mode is a feature for macOS 10.14 (Mojave) and later. Unfortunately, ScummVM doesn't support it.

To reproduce:

  1. Enable dark mode in macOS (see link above)
  2. Open ScummVM
  3. Note that the title bar is white, rather than dark like the rest of macOS
  4. Click "Add Game…"
  5. Note that the file picker is white, rather than dark like the rest of macOS

Attachments (1)

No Dark Mode in ScummVM.png (533.9 KB ) - added by Thunderforge 13 months ago.
Screenshot showing ScummVM not supporting macOS Dark Mode

Download all attachments as: .zip

Change History (10)

by Thunderforge, 13 months ago

Attachment: No Dark Mode in ScummVM.png added

Screenshot showing ScummVM not supporting macOS Dark Mode

comment:1 by Thunderforge, 13 months ago

Summary: Dark mode is not supportedDark Mode is not supported

comment:2 by Thunderforge, 13 months ago

Cc: Thunderforge added
Description: modified (diff)

comment:3 by criezy, 13 months ago

This is likely related to the fact we are using an older macOS SDK to build ScummVM. Indeed the Apple Developer documentation indicates that the system automatically opts in any app linked against the macOS 10.14 or later SDK to both light and dark appearances. There is a way to opt in when using an older SDK by setting the NSRequiresAquaSystemAppearance key to NO in the Info.plist file. I will take a look at this a bit later when I find the time to check that ScummVM behaves properly in Dark Mode.

Some more information:

comment:4 by criezy, 13 months ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

I have now tested that ScummVM works properly when opting in for the dark mode on macOS 10.15, and this was committed in 485e8be.

comment:5 by criezy, 9 months ago

Resolution: fixed
Status: closednew

I am reopening this bug as the addition of the NSRequiresAquaSystemAppearance key in the Info.plist file has been reverted. So we are lacking again dark mode support.

The issue is that it causes a blurry display for users with a Retina screen on macOS Mojave and Catalina. You can see details of the issue in bug #11430. I think the blurry display is a more serious issue than not supporting the dark theme.

comment:6 by raziel-, 6 months ago

Summary: Dark Mode is not supportedBACKENDS: MacOSX - Dark Mode is not supported

comment:7 by sev-, 5 months ago

Priority: normalhigh

comment:8 by sev-, 5 months ago

Priority: highnormal

comment:9 by dwatteau, 6 weeks ago

Hi,

As per https://bugs.scummvm.org/ticket/11430#comment:17, I think it could be possible to try enabling Dark Mode again (I can help you with some tests if necessary).

I'm keeping the details in the other ticket, though, since there are a lot of interactions between the blurriness bug on Retina displays, Dark Mode, SDK versions, SDL2 and so on.

Note: See TracTickets for help on using tickets.