#11303 closed defect (fixed)

KYRA: Kyrandia 1. Some bugs

Reported by: ctoroman Owned by: athrxx
Priority: normal Component: Engine: Kyra
Version: Keywords:
Cc: Game: Kyrandia 1

Description

Savegames in bugs.zip

Bug1: Go right. Sound effect is heard when changing background music
Bug2: Click on the purple stone on the amulet. Sound effect is heard.
Bug3: Click on the purple stone on the amulet. Sound effect is heard.
Bug4: Go up and right. Sound effect when leaving a cave.
Bug5: Drink an orange potion. The bottle remained full.
Bug6: Put a flower on the grave. After talking with a ghost, a sound effect is heard
Bug7: Click on the blue stone on the amulet. When the protective field disappears, Brandon continues to act on it.

Attachments (5)

bugs.zip (106.5 KB ) - added by ctoroman 16 months ago.
screen1.JPG (21.6 KB ) - added by ctoroman 16 months ago.
video1.mp4 (433.6 KB ) - added by ctoroman 16 months ago.
kyra1-cd.010 (15.0 KB ) - added by ctoroman 16 months ago.
kyra1-cd.004 (16.4 KB ) - added by ctoroman 16 months ago.

Download all attachments as: .zip

Change History (28)

by ctoroman, 16 months ago

Attachment: bugs.zip added

comment:1 by athrxx, 16 months ago

Now, that's plenty for a start :)

Which sound driver/emulator have you set?

comment:2 by ctoroman, 16 months ago

ScummVM v2.1
OS: Windows 10 x64 Pro

All drivers are original

In Kyrandia 2 and 3 there are no these effects :)

comment:3 by athrxx, 16 months ago

Thanks for the quick reply, but I was talking about the ScummVM sound settings. Is that AdLib (MameOPL, DosBox OPL or NukedOPL), General Midi, Roland-MT32 or something else?

Do you get a warning dialog when you start up the game ("You appear to be using General MIDI device, but your game only supports Roland MT-32...")?

comment:4 by ctoroman, 16 months ago

There was no such dialogue. All by default.
When Herman builds the bridge, bug №1 disappears.

I also found one small bug in Kyrandia 2 :)

Last edited 16 months ago by ctoroman (previous) (diff)

by ctoroman, 16 months ago

Attachment: screen1.JPG added

comment:5 by athrxx, 16 months ago

The thing is: I can't reproduce any of these sound bugs (sound effects that shouldn't be there). The sound effects get a bit weird when you select General MIDI sound, since there is no native support for that in Kyra 1. But it seems you haven't even selected that. If you don't change anything in the ScummVM settings you usually get MT-32 sound (or at least I do).

Do you - at Kyra startup - get a grey rectangle in the middle of the (otherwise black) screen that has a white "Westwood Studios" text in it?

BUGS 5/7: I compared both sequences with a Youtube video and these seem to be valid bugs indeed. I've also tested the Pegasus potion with the FM-Towns version. The bottle will actually be emptied in that version. The sequence looks even weirder, though: Brandon lowers the - still full - bottle after drinking and it gets empties during his arm movement. I'll have to examine this some more...

comment:6 by ctoroman, 16 months ago

No, i don't get rectangle at startup

comment:7 by athrxx, 16 months ago

Yes, that was wrong thinking on my part. You won't get MT-32 music, unless you have the required rom files (MT32_CONTROL.ROM and MT32_PCM.ROM). My best guess is that you're getting AdLib sound from the MameOPL emulator. That emulator is aiming more at performance than quality. Still, there shouldn't be any weird sound effects and I don't get any in my tests. You could try out NukedOPL for better quality. Or you get the MT32 rom files and use that...

Meanwhile I have fixed bugs 5 and 7. So that you at least get something from your bug report :)

comment:8 by ctoroman, 16 months ago

Thank You :)

Using the Nuked OPL did not work. I recorded this effect (video1.mp4)

by ctoroman, 16 months ago

Attachment: video1.mp4 added

comment:9 by athrxx, 16 months ago

Thanks for the video. This is really a noise that shouldn't be there. From the video I can hear that you do have AdLib sound. I am not sure which one.

Still, I cannot reproduce this on my system.
My thought was that it could be the (not so plesant) buildbot build that we offer on the website. But I just did a test with https://buildbot.scummvm.org/snapshots/master/mingw-w64-master-latest.zip and I still don't get that noise.

I'll have to examine that some more...

If it isn't too much of a bother, could you please try the following:

1) In the launcher, click on "Edit Game", then on the "Audio" tab, then check the box "Override global audio settings" and then in the dropdown list "Music Device" select "Microsoft GS Wavetable Synth [Windows Midi]". If you try out bug 1 now, is that noise still there?

2) After testing as described in 1), could you please in addition to the steps in 1) in the launcher click on the "MIDI" tab, then check the box "Override global MIDI settings", then check the box "Mixed AdLib/MIDI mode". Is the noise there again in bug 1?

Last edited 16 months ago by athrxx (previous) (diff)

comment:10 by ctoroman, 16 months ago

Thanks you.

After step No.1, the noise disappeared.
After step No.2, everything is also OK.

If I set up AdLib emulator,(step No.1), noise appears.

comment:11 by athrxx, 16 months ago

Thanks for doing those tests.

So this is probably an issue with our AdLib driver. It will be difficult to tackle, especially since I am not able to reproduce the issue and test any possible fixes.

Have you tried out the other two emulators in the "Audio" tab ("DOSBox OPL emulator" and "Nuked OPL emulator")? Does that noise appear with these emulators, too?

comment:12 by ctoroman, 16 months ago

Yes, noise is also present on these emulators.
The best option for me is Microsoft GS Wavetable Synth [Windows Midi] + Mixed AdLib / MIDI mode

I replayed the whole game again and noticed a couple more bugs:

  1. When you throw nuts in a hole, the earth does not shake.
  2. There is no sound of pressing the buttons of the amulet.
Last edited 16 months ago by ctoroman (previous) (diff)

by ctoroman, 16 months ago

Attachment: kyra1-cd.010 added

comment:13 by athrxx, 16 months ago

Thanks for your new findings :)

I've fixed the screen shakes. These were simply too fast to be actually seen. I added some delays. The shakes still aren't completely okay. They have to be bigger (depending on your scaler setting in the ScummVM launcher). But that's an issue outside the Kyra engine that has to be addressed separately.

I have checked the button click sounds with DOSBox. It seems that they don't work with AdLib. You get these sounds with every other sound setting, but the AdLib data seems to be broken somehow. I can see that the sounds data actually gets sent into the driver, but it doesn't produce any sound. Since it is the same thing in DOSBox and I can't fix broken sound data, you'll have to do without the button clicks...

comment:14 by ctoroman, 16 months ago

Thank you very much for the corrections! )
I played the game again from the beginning, and I want to make happy again with a new bug).
When you mix two potions into one, the last potion does not appear in the middle between the crystals, but at the place of the last application. (Bug No.8)

Last edited 16 months ago by ctoroman (previous) (diff)

by ctoroman, 16 months ago

Attachment: kyra1-cd.004 added

comment:15 by athrxx, 16 months ago

Okay, I'll check the thing with the potions. No idea whether it is a bug or not. Thanks for that :)

I've now made a fix to global ScummVM graphics code which should fix the screen shaking so that it looks correct.

Also, I've been able to reproduce the AdLib sound bugs. Not with Windows, but with Linux. Which mean I'll probably be able to fix them...

comment:16 by ctoroman, 16 months ago

This is very good, thank you very much)

comment:17 by athrxx, 16 months ago

Just for clarification regarding that potion mixing bug: I notice that the magic / sparkling animation does not take place where the potion is actually created. The potion gets created right in the middle of the crystals but the magic / spark thingy appears somewhere to the left or to the right. Is that what you were talking about?

comment:18 by ctoroman, 16 months ago

Yes, that's about it

comment:19 by athrxx, 16 months ago

I've committed a fix for the misplaced magic animation :)
Should be okay now.

comment:20 by ctoroman, 16 months ago

Yes, now everything is OK. Thanks a lot)

comment:21 by athrxx, 16 months ago

So, I think that I have actually managed to fix the AdLib music bug.

Could you please test whether this ugly noise is gone?

comment:22 by ctoroman, 16 months ago

I replayed the whole game. Yes, these noises are gone. Thank you!

comment:23 by athrxx, 16 months ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed

Thanks for the testing :)

Note: See TracTickets for help on using tickets.