#11302 closed enhancement (fixed)

King's Quest 7: Checksums for SoftClub version (official Russian CD)

Reported by: trcpman Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: unknown-game Cc:
Game: King's Quest 7

Description

ScummVM version: 2.1.0
Game version: Official Russian CD from SoftClub
OS: Windows 7 Pro x64

Hello. I've found Russian version of King's Quest 7 from SoftClub, but ScummVM doesn't know md5 checksums.
SoftClub version is an official version of game with speech, textures and video translate.

The game in 'Kings Quest 7 (RUS)\' seems to be an unknown game variant.

Matched game IDs for the SCI [all games] engine: kq7-win

{"resource.000", 0, "e6cee6c1ddb1e73e8c25d8f2a9f508ff", 200873632},
{"resource.map", 0, "dd1504ee0274e4e3b8447b25137136df", 18709},

Change History (15)

comment:1 by sluicebox, 11 months ago

Thank you for this, can you report the contents of the VERSION file so we can include that information in our detection table? It's just a small text file.

I didn't know about SoftClub until now but I see that we have a detection table entry for their release of Torin's Passage.

comment:2 by trcpman, 11 months ago

VERSION: 2.1b

comment:3 by m-kiewitz, 11 months ago

Can you please also tell us, if the Russian version is bilingual or Russian only.
Plus does it have Russian voices, or just Russian text?

comment:4 by trcpman, 11 months ago

Can you please also tell us, if the Russian version is bilingual or Russian only.

Only Russian.

Plus does it have Russian voices, or just Russian text?

Russian text, voices(dub) and video translate.

comment:5 by m-kiewitz, 11 months ago

voices(dub) and video translate

Wow, I didn't expect that.

@sluicebox
If you add it, please add corresponding flags.

comment:6 by sluicebox, 11 months ago

Added in: 3b441df98bb2cb2c2f6f950aad769b42c452e795

@trcpman: Thank you, this will appear in the next daily development build which will be labeled "Jan 4": https://buildbot.scummvm.org/builds.html. Can you please report back if this works for you? We are preparing version 2.1.1 for later this month and if you can verify this works then it can be included. I'll leave this ticket open for now.

@m-kiewitz I used the default KQ7 flags plus language, which is consistent with the other localized KQ7s and the SoftClub entry for Torin's Passage, let me know if I missed something. Or, just commit it? =)

comment:7 by trcpman, 11 months ago

I've checked last (4 Jan 2020) development build, everything fine exept one:

If i choose DOS version, text and voices translated to russian, but video intro not,
because disk has 2 version videos:

03.01.2020 00:20 <DIR> ..
08.11.1994 17:45 21 948 444 1
25.07.1995 19:27 24 701 699 91.RBT
26.07.1995 18:28 8 781 594 911.RBT
22.08.1995 18:13 1 373 456 912.RBT
19.08.2003 16:45 9 237 010 e108x11.avi
10.11.1994 19:47 2 014 412 E208X11.AVI
05.08.2003 16:01 22 052 864 INT08X11.AVI

Avi was translated, but other one not.

If i choose WIN version: text, voices and video translated.

comment:8 by m-kiewitz, 11 months ago

Can you please try to start the DOS version using the original interpreter?
Possibly the DOS version wasn't fully translated, but the Windows version was.

in reply to:  8 comment:9 by trcpman, 11 months ago

Replying to m-kiewitz:

Can you please try to start the DOS version using the original interpreter?

No, I can't do it, because disk doesn't have dos installer.

Possibly the DOS version wasn't fully translated, but the Windows version was.

There is no dos version, only non translated videos.
PS: I can provide iso image for testing.

comment:10 by m-kiewitz, 11 months ago

It also doesn't have a DOS interpreter?

Can you please provide a file listing of all the files that are on the CD?

If you could provide us with a way to purchase this version, that would be helpful.

in reply to:  10 comment:11 by trcpman, 11 months ago

Replying to m-kiewitz:

It also doesn't have a DOS interpreter?

I think no.

Can you please provide a file listing of all the files that are on the CD?

04.12.2003 16:03 225 241 ALTRES.000
04.12.2003 16:03 466 ALTRES.MAP
04.12.2003 16:03 466 ALTRES.MDT
04.12.2003 16:03 1 336 832 Autorun.exe
04.12.2003 16:03 42 autorun.inf
04.12.2003 16:03 263 287 data1.cab
04.12.2003 16:03 14 217 data1.hdr
04.12.2003 16:03 415 243 079 data2.cab
04.12.2003 16:03 418 296 engine32.cab
04.12.2003 16:03 766 KQ7W.ICO
04.12.2003 16:03 498 layout.bin
04.12.2003 16:03 200 873 632 RESOURCE.000
04.12.2003 16:03 317 resource.win
04.12.2003 16:03 143 642 SCIDLL.DLL
04.12.2003 16:03 405 649 setup.boot
04.12.2003 16:03 107 512 setup.exe
04.12.2003 16:03 387 setup.ini
04.12.2003 16:03 165 923 setup.inx
04.12.2003 16:03 324 559 SETUP.SOL
04.12.2003 16:03 9 378 SIERRA.ERR
04.12.2003 16:03 806 004 SIERRAW.EXE
04.12.2003 16:03 10 VERSION

If you could provide us with a way to purchase this version, that would be helpful.

Actually no, the disk has out of print for a long time.

comment:12 by m-kiewitz, 11 months ago

I meant maybe a way to buy a used copy.

If there is no DOS interpreter, I guess it's fine to make this release Windows only.

comment:13 by sluicebox, 11 months ago

I've removed the DOS detection entry since there is no DOS interpreter, and more importantly, since running in DOS mode causes the game scripts to play untranslated RBT files instead of the translated AVI files: ac850dbfaa6b6601a3f8dbfaf99341d6f809d800

Adding this to the 2.1 branch since it's been confirmed to work. Great find, trcpman!

comment:14 by sluicebox, 11 months ago

I am leaving this open for a while longer to not discourage trcpman from replying about where to get a hold of this game. =)

comment:15 by sluicebox, 11 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Presumably trcpman is out enjoying the adventures of Valanice and Rosella and doesn't know where we can buy their ancient CD.

Note: See TracTickets for help on using tickets.