#11294 closed defect (fixed)

BLADERUNNER: Game freezes if exiting from KIA when audio device disabled

Reported by: antoniou79 Owned by: antoniou79
Priority: normal Component: Engine: Bladerunner
Version: Keywords: freezing, disabled output sound device
Cc: antoniou79 Game: Blade Runner

Description

To reproduce in Windows 10, disable the audio output device from the "Manage Output devices" settings screen.

Currently, there will also be a logged warning:
WARNING: Could not open audio device: WASAPI can't find requested audio endpoint: Element not found.
WARNING: Sound initialization failed. This may cause severe problems in some games!

But the game will start. If an assertion fault is shown about _mixerReady, clicking ignore, will allow to proceed the game.

Related bugs:

  • The aforementioned assertion fault about _mixerReady in audio/mixer.cpp MixerImpl::playStream(), is thrown upon playing a new audio track (eg when each video cutscene starts)
  • Subtitles will show for video cutscenes but will not show for in-game quotes, because their display time depends on a respective sound resource playing with a non-zero duration. Subtitles will show up if sound is only muted (because the track is still "playing") but not when the audio device is completely disabled.

Change History (2)

comment:1 by antoniou79, 15 months ago

Windows (10?) seem to have a feature whereby if no output audio device is connected (or attached) to a PC (internal/external speakers, headphones, HDMI output etc) then the Windows "audio output device" gets disabled.

This would also lead to the issue of this bug ticket --as reported on GOG forums, where the user resolved the issue by connecting speakers to the PC.
https://www.gog.com/forum/blade_runner/blade_runner_game_keeps_on_crashing

comment:2 by antoniou79, 15 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.