Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#11289 closed defect (fixed)

KYRA: Kyrandia 2. Secret potion issue

Reported by: ctoroman Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 2

Description

Throw the ingredients into the cauldron:

  1. Whistle
  2. Crystal seeds
  3. Lollipop
  4. Feathers

Drink the potion.
The keyboard should become a musical instrument.
This is not happening.

Attachments (1)

Save1.zip (19.2 KB ) - added by ctoroman 10 months ago.

Download all attachments as: .zip

Change History (9)

by ctoroman, 10 months ago

Attachment: Save1.zip added

comment:1 by athrxx, 10 months ago

Component: --Unset--Engine: Kyra
Game: Kyrandia 2

Thanks for your report.

Interesting, I didn't know about that secret potion. I'll try to add the necessary code...

comment:2 by athrxx, 10 months ago

Owner: set to athrxx
Resolution: fixed
Status: newpending

I have added the missing code and committed a fix. This feature is a bit weird. You don't really get a midi keyboard or anything interesting like that, but the game will simply play certain sound effects for each key press.

I haven't tested the original with DosBox, since it would require me to play through the whole game. But the feature seems to work as intended...

Please note, that the activation of the musical keyboard will survive any reload of your game. If you load another savegame after drinking the secret potion the keyboard will still be activated. To get rid of the musical keyboard you have to quit (either completely or to the ScummVM launcher). However, if you save your game after drinking the secret potion this state will also be in your savefile.

comment:3 by ctoroman, 10 months ago

Thank you very much! But now this effect is turned on before drinking the potion :)

comment:4 by athrxx, 10 months ago

Thanks for your feedback.

I noticed that the keyboard is turned on when loading the savegame you provided, but not if I use a savegame of my own. I have tried with DOS/CD and with PC-98.

Did you maybe drink that potion and then reload and save again? Like I said in my other comment it is a bit difficult to get rid of that mode once it is enabled.

comment:5 by ctoroman, 10 months ago

I apologize. I replayed the game from the start. Everything is fine with this effect. Thanks again :) Happy New Year!

comment:6 by athrxx, 10 months ago

Status: pendingclosed

Great, thanks for doing another test.
And a Happy New Year to you, too! :)

comment:7 by sev-, 10 months ago

This is a test comment for checking the e-mail delivery. Please ignore.

comment:8 by lotharsm, 10 months ago

This is another test comment for checking the e-mail delivery. Please ignore again.

Note: See TracTickets for help on using tickets.