Opened 3 years ago

Last modified 7 months ago

#11274 new defect

SCI: Cannot input regional Polish characters, thus cannot finish the game

Reported by: DoktorBartasPL Owned by: sev-
Priority: normal Component: Engine: SCI
Version: Keywords: "Other" input
Cc: Game: Leisure Suit Larry 7

Description

Language of game - Polish
Version of game - GoG, newest SVM downloaded with game from GoG
Your OS, including version and device if appropriate - Win10

Using the "other input" command, Polish language players cannot type in Polish letters like ą, ę, ó. This blocks them from finishing the game, as you cannot type in "wydój" on the beaver at certain part of the game.
Tried to pass the letters via scripting, to no avail - the game doesn't recognize unicode sending etc. Most likely ScummVM blocks the use of ALT key which is used to input the characters.

Change History (10)

comment:1 by sev-, 3 years ago

Priority: blockernormal
Summary: Cannot input regional Polish characters, thus cannot finish the gameSCI: Cannot input regional Polish characters, thus cannot finish the game

comment:2 by sev-, 3 years ago

Owner: set to sev-
Resolution: fixed
Status: newpending

Fixed in f491a2562c396177349a1a3b232d0c37754476f8 (the build should be after Wed Dec 25 12:44:01 2019.

Could you please test? I added normal layout, no idea whether it will work with 'Alt', please test. If it does not work, could you then run scummvm with '-d1' parameter, and it should issue a debug output on the keypresses.

comment:3 by DoktorBartasPL, 3 years ago

Hi sev-, can you please share a link to some KDB telling how to run the debug console in LSL7?

  1. Downloaded and updated my version with the build, running fine.
  2. Added the CLI parameter.
  3. I cannot run the CTRL+D shortcut to view the debug console, as it's being overwritten with in-game functionality to "Decrease filth level".

Maybe it is possible to enable the virtual keyboard, with a custom keyboard mapping? Also tried Shift+~, followed by a letter, and it only enables on ó.
Possibly it's not gamebreaking, but still it may not be possible to max out the game.

comment:4 by sluicebox, 3 years ago

Hello DoktorBartasPL, the shortcut to bring up the debug console is CTRL + SHIFT + D.

comment:5 by DoktorBartasPL, 3 years ago

Thanks! Was able to bring it up. Checked debugging, and it's running level 1 debug. Nothing appeared in the console on keypress, both single strokes and key combinations (like ALT+A). Perhaps I need to enable some debug flags? Tried with String, no difference.

comment:6 by sev-, 3 years ago

Status: pendingclosed

Confirmed as fixed

comment:7 by kapela86, 3 years ago

Resolution: fixed
Status: closednew

It's not fully fixed. Can't input "ą" and "ś" using AltGr+a/s because they are detected as Ctrl+Alt+a/s.

comment:8 by sev-, 3 years ago

There is a limitation, Alt+a/s are already used for other functions (aspect ratio correction and screenshots). We made a compromise: press Alt+Shift+a/s. Thus, we lose the capitals of those letters, but they are very rarely used.

comment:9 by sev-, 3 years ago

Resolution: fixed
Status: newclosed

comment:10 by Offpics, 7 months ago

Resolution: fixed
Status: closednew

I'm not able to input Polish characters. I've tried Alt+a, Alt+Shift+a and nothing. Launching scummvm with debug level 1 does not print keystrokes to the stdout.

  • ScummVM version - ScummVM 2.5.1 (Jan  5 2022 13:37:42)
    Features compiled in: TAINTED Vorbis FLAC MP3 ALSA SEQ sndio TiMidity RGB zLib MPEG2 FluidSynth Theora AAC A/52 FreeType2 FriBiDi JPEG PNG GIF TTS cloud (servers, local) TinyGL OpenGL (with shaders) GLEW
    
  • OS: Arch with kernel 5.16.14-arch1-1
  • DE: Gnome
  • $localectl status
    System Locale: LANG=en_US.UTF-8
                      LC_NUMERIC=pl_PL.UTF-8
                      LC_TIME=pl_PL.UTF-8
                      LC_MONETARY=pl_PL.UTF-8
                      LC_PAPER=pl_PL.UTF-8
                      LC_NAME=pl_PL.UTF-8
                      LC_ADDRESS=pl_PL.UTF-8
                      LC_TELEPHONE=pl_PL.UTF-8
                      LC_MEASUREMENT=pl_PL.UTF-8
                      LC_IDENTIFICATION=pl_PL.UTF-8
           VC Keymap: pl2
          X11 Layout: pl
    
Note: See TracTickets for help on using tickets.