Opened 8 months ago

Closed 8 months ago

#11272 closed defect (fixed)

Bellboy dialog defect

Reported by: BlueMax Owned by: bluegr
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

The first interactive dialog (with the bellboy in the hotel lobby right at the start, 3rd screen) is buggy. Whatever you click results in 'i've gotta go now'.

ScummVM 2.1.0 (Oct 8 2019 07:07:07)
FOTAQ_Talkie-1.1
Arch Linux

Attachments (2)

queen.s00 (12.3 KB ) - added by BlueMax 8 months ago.
queen.2.s00 (12.3 KB ) - added by grgohr 8 months ago.
bellboy dialog exit whatever answer

Download all attachments as: .zip

Change History (7)

by BlueMax, 8 months ago

Attachment: queen.s00 added

comment:1 by digitall, 8 months ago

This works fine in v1.9.0, but is broken in the v2.1.0 release. Will try to bisect down to locate this regression

comment:2 by digitall, 8 months ago

Works fine in v2.0.0 (v1.10) as well, so will bisect between v2.1.0 and v2.0.0

Last edited 8 months ago by digitall (previous) (diff)

comment:3 by digitall, 8 months ago

Hmm.. Now fails to replicate with v2.1.0. It looks like this bug is unstable i.e. dependent on the exact sequence / timing of steps so this might be a script bug present in the original. I did skip the intro using ESC key which might cause glitches in the scripts..

@BlueMax: Can you try from a new game state, skip the intro and just go straight to Mike via the sheet puzzle and talk to him to see if you can still replicate?

comment:4 by digitall, 8 months ago

To be honest, this is pretty consistent with the latest v2.2.0git.

I am not sure, but the dialogue response sounds like the exit line from Joe/Ego when you stop talking to the Mike/NPC ... which could point at this recent change:
https://github.com/scummvm/scummvm/commit/0377045f0e27d60a5488bbc095b42866104f801d

by grgohr, 8 months ago

Attachment: queen.2.s00 added

bellboy dialog exit whatever answer

comment:5 by bluegr, 8 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.