Opened 8 months ago

Closed 6 months ago

#11271 closed defect (fixed)

GUI: PopUpControl text blank in UpdatesDialog

Reported by: sluicebox Owned by: bgK
Priority: low Component: GUI
Keywords: Cc:
Game:

Description

There's a minor graphics glitch in the UpdatesDialog that appears on startup when the updates_check setting doesn't exist yet.

The text in the PopUpWidget for the update-check interval is initially blank, even though it's initialized to Weekly, until moused over. After making a selection from the popup, the text is blank again until the mouse moves over it.

Attached are screenshots from:

  • Startup (blank text)
  • Clicking on field to bring up popup (the popup is okay)
  • Immediately after clicking the popup (blank text)

Occurs in 2.1.0 (and latest source) on at least Mac and Windows.

To reproduce, remove updates_check from scummvm.ini and run.

Attachments (3)

1-inital.png (12.6 KB ) - added by sluicebox 8 months ago.
2-popup.png (15.8 KB ) - added by sluicebox 8 months ago.
3-after-click.png (12.6 KB ) - added by sluicebox 8 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 by sluicebox, 8 months ago

Trac is broken and can't add attachments at the moment. I'll try again another day, but that should be enough to reproduce since it always happens.

by sluicebox, 8 months ago

Attachment: 1-inital.png added

by sluicebox, 8 months ago

Attachment: 2-popup.png added

by sluicebox, 8 months ago

Attachment: 3-after-click.png added

comment:2 by bgK, 6 months ago

Owner: set to bgK
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.