Opened 11 months ago

Closed 9 months ago

Last modified 8 months ago

#11241 closed defect (fixed)

XEEN: Crash when trying to enter Deep Mine Alpha

Reported by: RX4NT9UP Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Keywords: Cc:
Game: Might and Magic: World of Xeen

Description (last modified by RX4NT9UP)

Entering Deep Mine Alpha in the dwarven mines results in a crash with the following output:

scummvm: ./common/array.h:192: T& Common::Array<T>::operator[](Common::Array<T>::size_type) [with T = Xeen::MonsterStruct; Common::Array<T>::size_type = unsigned int]: Assertion `idx < _size' failed.
Aborted (core dumped)

To reproduce:
click on mine cart and type alpha

ScummVM version:
ScummVM 2.1.0 (Oct 12 2019 12:00:00)
Features compiled in: TAINTED Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG

Game Language:
ENGLISH

Game Version:
DOS CD

OS:
Linux OpenSuse Leap 15.1

Attachments (1)

worldofxeen-cd.001 (222.6 KB ) - added by RX4NT9UP 11 months ago.

Download all attachments as: .zip

Change History (10)

by RX4NT9UP, 11 months ago

Attachment: worldofxeen-cd.001 added

comment:1 by RX4NT9UP, 11 months ago

Description: modified (diff)

comment:2 by RX4NT9UP, 11 months ago

Description: modified (diff)

comment:3 by priiice, 10 months ago

Component: --Unset--Engine: Xeen
Summary: Crash when trying to enter Deep Mine AlphaXEEN: Crash when trying to enter Deep Mine Alpha

I can corroborate reproduction of this bug in my own playthrough. I'm using the 2.1.0 macOS 10.7+ 64-bit release binary.

comment:4 by JesseDyer, 9 months ago

Same issue here.
Ubuntu 19.10
ScummVM 2.2.0git1811-g4b3a5257f5 (Jan 5 2020 06:38:41)

Last edited 9 months ago by JesseDyer (previous) (diff)

comment:5 by dreammaster, 9 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

I was able to track down and fix the problem. It'll be available from the next nightly build.

comment:6 by JesseDyer, 9 months ago

Hey, was that to be in :

ScummVM 2.2.0git1851-g7d4045f4a9 (Jan 8 2020 06:31:17)

.. cause if so, I retested; still fails.

comment:7 by dreammaster, 9 months ago

Ironically, that looks like the build from the commit just before the commit that fixes it. Try again with tomorrow's build.

comment:8 by JesseDyer, 9 months ago

Retested : ScummVM 2.2.0git1884-ga18eae1067 (Jan 10 2020 06:15:22)

Still fails.

comment:9 by dreammaster, 8 months ago

Further experimentation revealed that the problem occurred in the non-CD World of Xeen version as well as the originally reported CD version. If that's the case for you, the next nightly should include the fix.

Note: See TracTickets for help on using tickets.