Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#11239 closed defect (fixed)

BLADERUNNER: Crash when visiting Yukon lobby in Act 4 (with CDFRAMES)

Reported by: Stefanic Owned by: antoniou79
Priority: normal Component: Engine: Bladerunner
Keywords: Unable to locate page, frame, animation, crash Cc: antoniou79, Stefanic
Game: Blade Runner

Description

I am playing through Blade Runner again (thanks for supporting this game btw!).

Currenly I am in act 4 (out on the streets section), but the game crashes/enters debugger when I try to enter the Yukon Hotel with the error below:

Unable to locate page 2214 for animation 668 frame 4!

I tried direct entry from DNA row and also made a round trip so you enter from the room where you where previously tied up, both result in this same error.

Let me know if I can help out with anything.

Attachments (2)

bladerunner-win.005 (32.6 KB ) - added by Stefanic 11 months ago.
Save game right before Yukon building (go left then up)
bladerunner-win.006 (32.6 KB ) - added by antoniou79 11 months ago.
Possible fixed saved game for #11239

Download all attachments as: .zip

Change History (16)

in reply to:  description ; comment:1 by antoniou79, 11 months ago

Replying to Stefanic:

I am playing through Blade Runner again (thanks for supporting this game btw!).

Currenly I am in act 4 (out on the streets section), but the game crashes/enters debugger when I try to enter the Yukon Hotel with the error below:

Unable to locate page 2214 for animation 668 frame 4!

I tried direct entry from DNA row and also made a round trip so you enter from the room where you where previously tied up, both result in this same error.

Let me know if I can help out with anything.

Hello! Which version of the game are you playing?

This error typically occurs if something is wrong with the required data files files that should be in your Blade Runner game folder that you added in Steam.

Could you please double check that you have all the correct files there?
We provide a list, and MD5 checksum per file for all known (to us) versions of the game:

Here's the pertinent links:

More often than not, this is due to some problem with the CDFRAMES#.DAT files (maybe there was a mixup as to their numbering during renaming?) or with the HDFRAMES.DAT (if you are using that one, and it is corrupted for some reason).

Also, if the bug persists after checking the above, please attach a save game in the report so that we can try to reproduce the issue.

comment:2 by antoniou79, 11 months ago

Cc: antoniou79 added
Keywords: Unable to locate page frame animation crash added

comment:3 by Stefanic, 11 months ago

Cc: Stefanic added

in reply to:  1 comment:4 by Stefanic, 11 months ago

Replying to antoniou79:

Hello! Which version of the game are you playing?

This error typically occurs if something is wrong with the required data files files that should be in your Blade Runner game folder that you added in Steam.

Could you please double check that you have all the correct files there?
We provide a list, and MD5 checksum per file for all known (to us) versions of the game:

Here's the pertinent links:

More often than not, this is due to some problem with the CDFRAMES#.DAT files (maybe there was a mixup as to their numbering during renaming?) or with the HDFRAMES.DAT (if you are using that one, and it is corrupted for some reason).

Also, if the bug persists after checking the above, please attach a save game in the report so that we can try to reproduce the issue.

I am playing the English CD release version, I checked all MD5 sums and they all match.
The MD5 hash also corresponds to the correct number of CDFRAMES*.DAT, so that must also mean the naming is correct.

I will attach my save game, you only need to walk to the right and then up. That takes you to the entrance to the Yukon.

by Stefanic, 11 months ago

Attachment: bladerunner-win.005 added

Save game right before Yukon building (go left then up)

comment:5 by antoniou79, 11 months ago

Yes, it was easy to reproduce from your savegame file. It indeed seems to be a bad state for the Desk Clerk that is causing it.

Did you quickly run past Leon chocking the Clerk in chapter 3?

The issue will not cause a crash (it's still a buggy state) if you are using the HDFRAMES.DAT method rather than the CDFRAMES#.DAT files, by the way. However, it's good to know about this bug so that we can prevent it from happening.

Last edited 11 months ago by antoniou79 (previous) (diff)

in reply to:  5 ; comment:6 by Stefanic, 11 months ago

Replying to antoniou79:

Did you quickly run past Leon chocking the Clerk in chapter 3?

Exactly that, I accidentally walked out of that scene and returned immediately but it was already over.

The issue will not cause a crash (it's still a buggy state) if you are using the HDFRAMES.DAT method rather than the CDFRAMES#.DAT files, by the way. However, it's good to know about this bug so that we can prevent it from happening.

Do you mean I should use the packing method to not trigger this bug?

in reply to:  6 ; comment:7 by antoniou79, 11 months ago

Replying to Stefanic:

Replying to antoniou79:

Did you quickly run past Leon chocking the Clerk in chapter 3?

Exactly that, I accidentally walked out of that scene and returned immediately but it was already over.

The issue will not cause a crash (it's still a buggy state) if you are using the HDFRAMES.DAT method rather than the CDFRAMES#.DAT files, by the way. However, it's good to know about this bug so that we can prevent it from happening.

Do you mean I should use the packing method to not trigger this bug?

I'm just remarking that the game won't crash with HDFRAMES.DAT to keep a note of it for the bug fix purposes.

I can upload your saved game fixed, so that you can continue playing without HDFRAMES.DAT.

Ideally we'd want to catch as many similar bugs as possible for when playing with the CDFRAMES#.DAT files.

in reply to:  7 comment:8 by Stefanic, 11 months ago

Replying to antoniou79:

I'm just remarking that the game won't crash with HDFRAMES.DAT to keep a note of it for the bug fix purposes.

I can upload your saved game fixed, so that you can continue playing without HDFRAMES.DAT.

Ideally we'd want to catch as many similar bugs as possible for when playing with the CDFRAMES#.DAT files.

If you can fix the savegame please, I will resume playing that save.

by antoniou79, 11 months ago

Attachment: bladerunner-win.006 added

Possible fixed saved game for #11239

comment:9 by antoniou79, 11 months ago

Can you try with the above attached save game please?

comment:10 by antoniou79, 11 months ago

In 1428aae3:

BLADERUNNER: #11239 Fix buggy state and saved games for Desk Clerk

Resolves ticket #11239

Occurs when McCoy leaves the scene with Leon and Desk Clerk too fast, before Leon drops the clerk
Crash happens only when using CDFRAMES, but the animation would be bugged even when using HDFRAMES.DAT

comment:11 by antoniou79, 11 months ago

Summary: Debugger starts after error 'Unable to locate page'BLADERUNNER: Debugger starts after error 'Unable to locate page'

comment:12 by antoniou79, 11 months ago

In 5f889bc9:

BLADERUNNER: #11239 Fix buggy state and saved games for Desk Clerk

Resolves ticket #11239

Occurs when McCoy leaves the scene with Leon and Desk Clerk too fast, before Leon drops the clerk
Crash happens only when using CDFRAMES, but the animation would be bugged even when using HDFRAMES.DAT

comment:13 by Stefanic, 11 months ago

Thanks for the fixed savegame, works like a charm!

comment:14 by antoniou79, 11 months ago

Owner: set to antoniou79
Resolution: fixed
Status: newclosed
Summary: BLADERUNNER: Debugger starts after error 'Unable to locate page'BLADERUNNER: Crash when visiting Yukon lobby in Act 4 (with CDFRAMES)

Excellent. I'm closing the ticket since the bug fix is now implemented for the development version and also back-ported to the possible 2.1.1 version.

Also, it might be worth noting that is a bug for the original game, too.

Last edited 11 months ago by antoniou79 (previous) (diff)
Note: See TracTickets for help on using tickets.