#11229 closed defect (fixed)

Phantasmagoria 1 Pixelated Censorship Not Implemented

Reported by: Gimlao Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Phantasmagoria 1

Description

If the censor option is enabled, every FMV cutscenes will crash the game.

Attachments (2)

Image1.png (104.2 KB ) - added by Gimlao 12 months ago.
Image2.png (11.4 KB ) - added by Gimlao 12 months ago.

Download all attachments as: .zip

Change History (7)

by Gimlao, 12 months ago

Attachment: Image1.png added

by Gimlao, 12 months ago

Attachment: Image2.png added

comment:1 by sluicebox, 11 months ago

Component: --Unset--Engine: SCI
Game: Phantasmagoria 1
Keywords: sci32 added

comment:2 by sluicebox, 11 months ago

Summary: Phantasmagoria 1 [French] FMV Cutscenes Crash if Censor Option is EnabledPhantasmagoria 1 FMV Cutscenes Crash if Censor Option is Enabled

This happens in English version 1.000.000 too, so presumably all versions. Yikes! Can it really be that this is the first time anyone has tried to use the censored option?

While trying to test this, I found that saving the game didn't persist the censorship option. It always restored to uncensored and I had to set a password again to set it to censored. I don't know if that's expected or not.

comment:3 by sluicebox, 11 months ago

The problem is that the "blob" engine feature isn't implemented in ScummVM. Script 26 contains a list of rectangles that are passed to kPlayVMD subops to draw over videos in censored mode.

The password decryption was indeed broken, that's now fixed: https://github.com/scummvm/scummvm/commit/b658ef31deb46019359824da5deba62295ffa990

Last edited 11 months ago by sluicebox (previous) (diff)

comment:4 by sluicebox, 11 months ago

Summary: Phantasmagoria 1 FMV Cutscenes Crash if Censor Option is EnabledPhantasmagoria 1 Pixelated Censorship Not Implemented

The video pixelation isn't implemented yet, but the videos will now play without crashing in censored mode as of https://github.com/scummvm/scummvm/commit/b6692ac7831a9475fd23f104145254d8dd507c27

This will appear in the next nightly build. All the other censorship features should now work.

This really might be the first time anyone tried this in ScummVM, including developers, because there was another bug that prevented the videos from ever playing beyond the first frame.

Leaving this open until pixelation is implemented, which I'm working on.

comment:5 by sluicebox, 11 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Pixelated censorship is now implemented: https://github.com/scummvm/scummvm/commit/05b21ace680d65336219a74cd87696eb157f7e84

This will appear in the next nightly build.

Thanks for reporting this, I've been looking for an excuse to learn this game and this was fun.

Note: See TracTickets for help on using tickets.