Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#11228 closed defect (fixed)

XEEN: Wrong position after Sign In in Swords of Xeen

Reported by: yarolig Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Keywords: Inn Cc: yarolig
Game: Might and Magic: Swords of Xeen

Description

When you exit from Sign In mode at the Inn at City of GrayHaven you appear inside a wall. Fortunately you can break the west wall :).

Versions:
I checked ScummVM 2.2.0git558-gf1b0ec772c and ScummVM 2.1.0.

To reproduce:

  1. Start Swords of Xeen
  2. Start a new game, enter the Inn, Sign In, exit. (S, A, Space x4, Up x2, Left, Up x10, Space, S, X)
  3. You are at x=10, y=8, facing south. You should be at x=9, y=2, facing west.

Language of game: English
Version of game: from gog.com
OS: Debian 10 x86_64

Change History (3)

comment:1 by dreammaster, 12 months ago

Hmm.. looks like they, understandably, had differing exit points for Swords, reflecting the different town maps. Looks like I'll need to break out my disassembly of the Swords executable and locate the relevant code changes.

comment:2 by dreammaster, 12 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

comment:3 by dreammaster, 12 months ago

Summary: Wrong position after Sign In in Swords of XeenXEEN: Wrong position after Sign In in Swords of Xeen
Note: See TracTickets for help on using tickets.